Closed Bug 928734 Opened 6 years ago Closed 6 years ago

Intermittent test_419731.js | "title 2" == "new title 1" - See following stack:

Categories

(Toolkit :: Places, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
firefox28 --- fixed
firefox29 --- fixed
firefox30 --- fixed
firefox-esr24 --- unaffected
b2g-v1.3 --- fixed
b2g-v1.4 --- fixed

People

(Reporter: philor, Assigned: mak)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=29334876&tree=Fx-Team
Windows XP 32-bit fx-team opt test xpcshell on 2013-10-18 15:35:07 PDT for push f1b97193d162
slave: t-xp32-ix-065

15:44:01  WARNING -  TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\xpcshell\tests\toolkit\components\places\tests\unit\test_419731.js | test failed (with xpcshell return code: 0), see following log:
15:44:01     INFO -  >>>>>>>
15:44:01     INFO -  TEST-INFO | (xpcshell/head.js) | test MAIN run_test pending (1)
15:44:01     INFO -  TEST-PASS | C:/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_419731.js | [run_test : 70] 1 == 1
15:44:01     INFO -  TEST-PASS | C:/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_419731.js | [run_test : 75] "foo" == "foo"
15:44:01     INFO -  TEST-PASS | C:/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_419731.js | [run_test : 79] [xpconnect wrapped (nsISupports, nsINavHistoryResultNode, nsINavHistoryContainerResultNode)] != [xpconnect wrapped nsINavHistoryResultNode]
15:44:01     INFO -  TEST-PASS | C:/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_419731.js | [run_test : 82] "bar" == "bar"
15:44:01     INFO -  TEST-PASS | C:/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_419731.js | [run_test : 86] 1 == 1
15:44:01  WARNING -  TEST-UNEXPECTED-FAIL | C:/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_419731.js | "title 2" == "new title 1" - See following stack:
15:44:01     INFO -  JS frame :: C:/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unit/test_419731.js :: run_test :: line 88
15:44:01     INFO -  JS frame :: C:\slave\test\build\tests\xpcshell\head.js :: _execute_test :: line 348
15:44:01     INFO -  JS frame :: -e :: <TOP_LEVEL> :: line 1
15:44:01     INFO -  native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
15:44:01     INFO -  TEST-INFO | (xpcshell/head.js) | exiting test
15:44:01     INFO -  <<<<<<<
I think the problem is that lastModified of bookmark1 ends up being same as bookmark2, our discarding code may then take a random one. we should enforce lastModified
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attached patch patch v1Splinter Review
most of this is cleanup you can ignore, the patch only changes this:

  // change bookmark 1 title
  PlacesUtils.bookmarks.setItemTitle(bookmark1id, "new title 1");

  // Workaround timers resolution and time skews.
  let bookmark2LastMod = PlacesUtils.bookmarks.getItemLastModified(bookmark2id);
  PlacesUtils.bookmarks.setItemLastModified(bookmark1id, bookmark2LastMod + 1);

I added the workaround to enforce proper ordering
Attachment #8366651 - Flags: review?(mano)
https://hg.mozilla.org/mozilla-central/rev/ee98436d195d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.