Closed Bug 928800 Opened 6 years ago Closed 6 years ago

Doorhanger not anchored on awesomebar (Tablets)

Categories

(Firefox for Android :: Awesomescreen, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 28
Tracking Status
firefox26 --- verified
firefox27 --- verified
firefox28 --- verified
b2g-v1.2 --- unaffected
fennec 26+ ---

People

(Reporter: gcp, Assigned: sriram)

Details

Attachments

(2 files)

Attached image Screenshot example
Nexus 7 (2013), portrait mode

Use a site that triggers a password storage Doorhanger. The Doorhanger sticks to the top of the screen instead of the Awesomebar.
Rotation prior? Bug 739205.
The device was held in portrait mode throughout.
This looks like what we do when the anchor view (the view that hold the favicon) is null.

Is this a recent regression, or does this happen on all release channels?
This doesn't reproduce on Nightly, but it does reproduce on Beta.
Hmm, it seems the STR aren't 100% reliable. I just managed to reproduce it on Nightly in Landscape mode, but I don't know what exact conditions trigger this.
Summary: Password storage doorhanger mispositioned on Tablets in portrait mode → Password storage doorhanger mispositioned on Tablets
Margaret, is there anything I can log that would help nail this down? I can reproduce it say 50% of the time.
Flags: needinfo?(margaret.leibovic)
Just reproduced it on the gum test page on my Tab 10.1/3.2, with a gum permissions doorhanger.
Summary: Password storage doorhanger mispositioned on Tablets → Doorhanger not anchored on awesomebar (Tablets)
tracking-fennec: --- → ?
Assignee: nobody → sriram
tracking-fennec: ? → 26+
Flags: needinfo?(sriram)
This usually happens when the anchor is not available/hidden. Is it possibility due to dynamic toolbar? I fixed that issue long back.

@Margaret: Aren't you taking care of doorhangers?
(In reply to Sriram Ramasubramanian [:sriram] from comment #8)

> @Margaret: Aren't you taking care of doorhangers?

This is on Fx26 and Margaret is booked with some other work at the moment.
Attached patch PatchSplinter Review
Whenever there is a change in the dynamic toolbar, if the doorhanger is shown, it's position is updated. Calling just update() does nothing useful for us. Instead, I'm calling show(), which will either update the location or show as drop-down depending on whether it is showing or not.
Attachment #832615 - Flags: review?(mark.finkle)
Flags: needinfo?(sriram)
Comment on attachment 832615 [details] [diff] [review]
Patch

Let's make sure phones and tablets are both working fine with this patch.
Attachment #832615 - Flags: review?(mark.finkle) → review+
Looks like Sriram has this under control.
Flags: needinfo?(margaret.leibovic)
Comment on attachment 832615 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Dynamic toolbar.
User impact if declined: Doorhanger wont be anchored properly.
Testing completed (on m-c, etc.): Landed in fx-team today.
Risk to taking this patch (and alternatives if risky): This patch updates the location based on dynamic toolbar's visibility. If the dynamic toolbar shows up when doorhanger is showing, it realigns itself. If has a low risk.
String or IDL/UUID changes made by this patch: None.
Attachment #832615 - Flags: approval-mozilla-beta?
Attachment #832615 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/46c21551ce22
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Attachment #832615 - Flags: approval-mozilla-beta?
Attachment #832615 - Flags: approval-mozilla-beta+
Attachment #832615 - Flags: approval-mozilla-aurora?
Attachment #832615 - Flags: approval-mozilla-aurora+
Unless I'm seriously misunderstanding something, this bug is purely Android/Java and never affected B2G.
Tested with Galaxy Tab  (4.0) using:
Firefox 26 Beta 8 
Firefox 27.0a2
Firefox 28.0a1

I can not reproduce it both at password nor at Gum Test (share mic/camera). Marking this Verifed fixed.
You need to log in before you can comment on or make changes to this bug.