RIL not working on Nexus S

RESOLVED DUPLICATE of bug 813042

Status

Firefox OS
RIL
RESOLVED DUPLICATE of bug 813042
4 years ago
4 years ago

People

(Reporter: past, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

Created attachment 819597 [details]
Logcat with RIL debugging enabled

My Nexus S can't function as a telephone since forever. I'm not sure where the problem lies, but I've finally gotten around to capturing a log with RIL debugging enabled, so hopefully someone will be able to figure it out. This is from the master branch (1.3), but the behavior was present in 1.2, 1.1, etc. My SIM card is from Vodafone GR, but I got the device in the US, in case it matters.

Other than this minor detail, the phone functions reasonably well with Firefox OS lately.
Can you specify what kinds of problems you met first?

You mean you cannot make a phone call? Or cannot receive call?
Or cannot have a Data connection? 
Or the phone crashes/restarts when you insert the SIM?

Thanks

Comment 2

4 years ago
Hi Panos:
 it looks like device get "voda GR" service after boot-up.

Boot-up -> request SIM PIN -> enter SIM PIN -> get "202-05 Voda GR" service. 

There is only one thing weird, signal stay at -99 (menas some problem on signal display)
Did you try to make a call on that device?


// Final state
I/Gecko   (   77): RIL Worker[0]: All pending network info has been received: {"rilMessageType":"networkinfochanged", ... ,"voiceRegistrationState":{"regState":1,"state":"registered","connected":true,"roaming":false,"emergencyCallsOnly":false,"cell":{"gsmLocationAreaCode":80,"gsmCellId":25347},..."rilMessageType":"voiceregistrationstatechange"},..."operator":{"rilMessageType":"operatorchange","longName":"vodafone GR","shortName":"voda GR","mcc":"202","mnc":"05"}}



I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'null' to 'off'
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'off' to 'ready'
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'ready' to 'ready'
I/Gecko   (   77): RIL Worker[0]: Queuing voiceRegistrationState network info message: {"regState":13,"state":"denied","connected":false,"roaming":false,"emergencyCallsOnly":true,"cell":{"gsmLocationAreaCode":0,"gsmCellId":0},"radioTech":0,"type":null,"rilMessageType":"voiceregistrationstatechange"}
I/Gecko   (   77): RIL Worker[0]: Queuing voiceRegistrationState network info message: {"regState":13,"state":"denied","connected":false,"roaming":false,"emergencyCallsOnly":true,"cell":{"gsmLocationAreaCode":51,"gsmCellId":2622},"radioTech":0,"type":null,"rilMessageType":"voiceregistrationstatechange"}
I/Gecko   (   77): RIL Worker[0]: iccStatus: {"cardState":1,"universalPINState":3,"gsmUmtsSubscriptionAppIndex":0,"cdmaSubscriptionAppIndex":0,"imsSubscriptionAppIndex":-1,"apps":[{"app_type":1,"app_state":2,"perso_substate":0,"aid":null,"app_label":null,"pin1_replaced":0,"pin1":1,"pin2":0}]}
I/Gecko   (   77): RIL Worker[0]: Handling parcel as REQUEST_ENTER_SIM_PIN
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'ready' to 'ready'
I/Gecko   (   77): RIL Worker[0]: iccStatus: {"cardState":1,"universalPINState":3,"gsmUmtsSubscriptionAppIndex":0,"cdmaSubscriptionAppIndex":0,"imsSubscriptionAppIndex":-1,"apps":[{"app_type":1,"app_state":5,"perso_substate":0,"aid":null,"app_label":null,"pin1_replaced":0,"pin1":2,"pin2":0}]}
I/Gecko   (   77): RIL Worker[0]: Queuing voiceRegistrationState network info message: {"regState":1,"state":"registered","connected":true,"roaming":false,"emergencyCallsOnly":false,"cell":{"gsmLocationAreaCode":80,"gsmCellId":25347},"radioTech":0,"type":null,"rilMessageType":"voiceregistrationstatechange"}
I/Gecko   (   77): RIL Worker[0]: All pending network info has been received: {"rilMessageType":"networkinfochanged","signal":{"voice":{"signalStrength":-99,"relSignalStrength":44},"data":{"signalStrength":-99,"relSignalStrength":44},"rilMessageType":"signalstrengthchange"},"voiceRegistrationState":{"regState":1,"state":"registered","connected":true,"roaming":false,"emergencyCallsOnly":false,"cell":{"gsmLocationAreaCode":80,"gsmCellId":25347},"radioTech":0,"type":null,"rilMessageType":"voiceregistrationstatechange"},"dataRegistrationState":{"regState":12,"state":"searching","connected":false,"roaming":false,"emergencyCallsOnly":true,"cell":{"gsmLocationAreaCode":80,"gsmCellId":25347},"radioTech":1,"type":"gprs","rilMessageType":"dataregistrationstatechange"},"operator":{"rilMessageType":"operatorchange","longName":"vodafone GR","shortName":"voda GR","mcc":"202","mnc":"05"}}
(Reporter)

Comment 3

4 years ago
Created attachment 819632 [details]
Logcat from boot including an attempted call

(In reply to Yoshi Huang[:allstars.chh][:yoshi] from comment #1)
> Can you specify what kinds of problems you met first?
> 
> You mean you cannot make a phone call? Or cannot receive call?
> Or cannot have a Data connection? 
> Or the phone crashes/restarts when you insert the SIM?

Sorry, I should have been more clear: the phones is still functional, but no call-related functionality works. I am attaching another log from a session where I tried to make a call (only to receive a message to disable airplane mode) and went through the various RIL-related settings pages, where no operator settings appear in data/message/a-gps settings pages (only the option to provide custom settings).

I should also note that the operator's menu doesn't appear in the settings at all (unlike my Unagi).
Attachment #819597 - Attachment is obsolete: true
(Reporter)

Comment 4

4 years ago
Created attachment 819633 [details]
Screenshot from settings

Here is what the settings app looks like.
(Reporter)

Comment 5

4 years ago
Created attachment 819635 [details]
Screenshot from call settings

Here is what the call settings page looks like.

Comment 6

4 years ago
I/Gecko   (   77): RIL Worker[0]: Unsolicited response for request type 1034
I/Gecko   (   77): RIL Worker[0]: Handling parcel as UNSOLICITED_RIL_CONNECTED
I/Gecko   (   77): RIL Worker[0]: Handling parcel as UNSOLICITED_RESPONSE_RADIO_STATE_CHANGED
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'null' to 'off'
I/Gecko   (   77): RIL Worker[0]: Handling parcel as UNSOLICITED_RESPONSE_RADIO_STATE_CHANGED
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'off' to 'ready'
I/Gecko   (   77): RIL Worker[0]: Handling parcel as UNSOLICITED_RESPONSE_RADIO_STATE_CHANGED
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'ready' to 'ready'
I/Gecko   (   77): RIL Worker[0]: Handling parcel as UNSOLICITED_RESPONSE_RADIO_STATE_CHANGED
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'ready' to 'ready'
I/Gecko   (   77): RIL Worker[0]: Unsolicited response for request type 1034
I/Gecko   (   77): RIL Worker[0]: Handling parcel as UNSOLICITED_RIL_CONNECTED
I/Gecko   (   77): RIL Worker[0]: Handling parcel as UNSOLICITED_RESPONSE_RADIO_STATE_CHANGED
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'null' to 'null'
I/Gecko   (   77): RIL Worker[0]: Handling parcel as UNSOLICITED_RESPONSE_RADIO_STATE_CHANGED
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'null' to 'off'
I/Gecko   (   77): RIL Worker[0]: Handling parcel as UNSOLICITED_RESPONSE_RADIO_STATE_CHANGED
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'null' to 'null'
I/Gecko   (   77): RIL Worker[0]: Handling parcel as UNSOLICITED_RESPONSE_RADIO_STATE_CHANGED
I/Gecko   (   77): RIL Worker[0]: Radio state changed from 'null' to 'off'
I/Gecko   (   77): TelephonyProvider: Dialing 121
I/Gecko   (   77): RIL Worker[0]: Received chrome message {"number":"121","isDialEmergency":false,"rilMessageToken":16,"rilMessageType":"dial"}
I/Gecko   (   77): -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"callError","callIndex":-1,"errorMsg":"RadioNotAvailable"}
(In reply to Panos Astithas [:past] from comment #3)
> Created attachment 819632 [details]
> Logcat from boot including an attempted call

line 1295

I/Gecko   (   77): RIL Worker[0]: New outgoing parcel of type 68
I/Gecko   (   77): RIL Worker[0]: Outgoing parcel: 0,0,0,96,68,0,0,0,64,0,0,0,40,0,0,0,50,0,66,0,69,0,51,0,70,0,70,0,55,0,70,0,55,0,70,0,48,0,49,0,48,0,48,0,53,0,70,0,52,0,66,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,48,0,0,0,0,0
I/Gecko   (   77): RIL Worker[0]: Next parcel size unknown, going to sleep.
F/<unknown>(   81): stack corruption detected: aborted
I/Gonk    (   77): RIL[0]: OnDisconnect


You got Bug 813042.
(Reporter)

Comment 8

4 years ago
Thanks, I'm building right now with the patch from that bug.
(Reporter)

Comment 9

4 years ago
Yep, that patch fixes it for me.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 813042
You need to log in before you can comment on or make changes to this bug.