BaselineCompiler: return correct *pc when in prologue

RESOLVED FIXED in mozilla27

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: h4writer, Assigned: h4writer)

Tracking

unspecified
mozilla27
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Got sudden failures when prototyping recompile without invalidation. I traced it back to an *pc that got set to "0". This is off course bogus, we should set it to script->code if we want the begin of the script.
(Assignee)

Comment 1

5 years ago
Created attachment 819682 [details] [diff] [review]
Setting pc to the right value
Assignee: nobody → hv1989
Attachment #819682 - Flags: review?(jdemooij)
(Assignee)

Comment 2

5 years ago
Asked Jan to review, since he already confirmed on IRC this was bogus and agreed with the fix. CC'ing Kannan since his patch introduced this bug: Bug 857838.
Blocks: 918278, 857838

Updated

5 years ago
Attachment #819682 - Flags: review?(jdemooij) → review+
https://hg.mozilla.org/mozilla-central/rev/f92a77d8ee8f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
You need to log in before you can comment on or make changes to this bug.