Geolocation not working in Aurora 26.0a2 on Win7 x64

RESOLVED WORKSFORME

Status

()

Core
Geolocation
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Rob Crowther, Unassigned)

Tracking

26 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox25 unaffected, firefox26 affected, firefox27 affected)

Details

(Reporter)

Description

4 years ago
Visiting http://mozqa.com/data/firefox/geolocation/position.html in Firefox Aurora 26.0a2 (2013-10-20) on Windows 7 64bit fails to pop up the Geolocation dialogue or pick up any co-ordinates.  No errors or timeouts are logged in the console.  Tried creating a new profile and a complete re-install of the browser but no change.

The same page on the same machine works fine in both Beta and Nightly.  I've copied the same install of Aurora on to a Windows Vista 32bit VM and it works fine there.

Possibly related to https://bugzilla.mozilla.org/show_bug.cgi?id=888252
(In reply to Rob Crowther from comment #0)
> fails to pop up the Geolocation dialogue
click once in the browser layout. doesn't appear now ?
(Reporter)

Comment 2

4 years ago
Clicking all over the browser fails to produce the Geolocation pop up dialogue.
status-firefox25: --- → unaffected
status-firefox26: --- → affected
status-firefox27: --- → affected
Summary: Geolocation not working in Aurora on Win7 x64 → Geolocation not working in Aurora 26.0a2 on Win7 x64
Sorry, I'm not able to reproduce on 26.0a2 (2013-10-20), Win 7 x64.
Rob, can you please test it with a new user on that affected Windows 7 machine? It could be that a profile wide system setting is preventing that.
(Reporter)

Comment 5

4 years ago
I can do, but can you explain why you think beta and nightly are not affected by the same setting?
(Reporter)

Comment 6

4 years ago
OK, now I'm back from logging in as a brand new user I have some stuff of interest to report.  Here's what I did:

1. Launched Aurora
  - Aurora auto-creates default profile
  - Geolocation doesn't work as described above
2. Closed Aurora and launched Nightly
  - Nightly uses default profile created by Aurora
  - Geolocation doesn't work as described above
3. Used Profile manager in Nightly to create new profile called nightly
4. Launched Nightly using -p nightly command line switch
  - Nightly uses nightly profile
  - Geolocation doesn't work as described above
5. Used Profile manager to delete all profiles
6. Launched Firefox release version (24)
  - Firefox auto-creates default profile
  - Geolocation *does work*
7. Closed Firefox and launched Aurora
  - Aurora uses default profile created by Firefox
  - Geolocation *does work*

From the above it seems to me that my problem is caused by something in the profile creation process in Aurora (and Nightly).  I don't see the problem in Nightly on my normal logon because that profile was originally created a long time ago, whereas the Aurora profile was created last week when I was trying to debug the original issue.

Will now try deleting my Aurora profile on my normal login and creating a new one in Firefox release to see if that resolves the issue in bug 888252.
(Reporter)

Comment 7

4 years ago
From further experiments in my normal domain login, it appears that the profile should be used in release Firefox to make a successful geolocation request before using it in Aurora.  After that things work fine.  Can't investigate much further now as I have to get on with actual work.
Those are some good news, Rob! When you find the time can you do one further test? In an affected profile created with Beta can you delete the profiles.ini in the profile folder while Firefox is closed? How does Aurora behave after a restart? Doesn't it work? If thats the case there is a config setting which is causing this problem.
(Reporter)

Comment 9

4 years ago
Just getting back to this, sorry, been busy.  If I delete profiles.ini isn't Aurora just going to use the default profile as per my steps 1, 2 and 7 above?
Oh, sorry. I meant to delete the prefs.js file in the profile folder itself.
(Reporter)

Comment 11

4 years ago
Sorry for the delay.  I can confirm that deleting the prefs.js file makes no difference, Aurora (now v27) does not pop up the permission dialogue for geolocation.
http://mozqa.com/data/firefox/geolocation/position.html works fine in 30.0a1 (2014-03-14), 29.0a2 (2014-03-14) Win 7 x64
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.