Closed Bug 928901 Opened 6 years ago Closed 6 years ago

Highlight threads needing attention for thread contributors

Categories

(support.mozilla.org :: Questions, task, P2)

Tracking

(Not tracked)

RESOLVED FIXED
2013Q4

People

(Reporter: atopal, Assigned: rehan)

References

Details

(Whiteboard: u=user c=questions p=3 s=2013.24 [needsverify])

Attachments

(5 files, 2 obsolete files)

As a forum contributor I want to have a view that clearly highlights all the threads that need my attention right now so I can get back to them quickly and increase their chance of being solved.

Currently forum contributors have a "my contributions" list, but it lists all the threads they have posted to in reverse chronological order (by the last activity), without any regard for the status of the thread. There should be a view that highlights the threads where the original poster is the last one to have left a message and the thread is not marked as solved.
This is cool but how often do contributors scroll back to their list of contributions? I certainly don't.
Component: Knowledge Base Software → Questions
I think this is exactly the point Andrew, contributors do not scroll back to the list because it is difficult to actually do that. The idea is that we make this easy so that people can see which of the thread where they already replied need more attention i.e the OP came back with more info, the OP says the problem is still there etc
Just to add my two cents.

"There should be a view that highlights the threads where the original poster is the last one to have left a message and the thread is not marked as solved."

And this view should be easily discoverable. Maybe a notification next to your name when signed in.
Attached image forum.png
Here is my first proposal, built on top of the thinking that went into bug 936718. 

We want to divide the forum into 3 primary areas:
* Need Attention
* Responded
* Done

The focus is on "Needs Attention". That's where we want to steer people to. The goal is to have as few question for as short as possible in that area.

The "Needs Attention" area should be further subdivided into "new" questions and questions where the "answer didn't help". People should be able to see one or the other or both. By default we'd display both kinds of questions.

Questions can also be escalated or off-topic. These are not states, but additional information about questions that people can use to decide if they want to get involved. By default we would not show off-topic or escalated questions.

On top of that we have the "mine/all" layer that would show questions I have been involved in and all questions. This would work across the 3 areas. 

In total, the layers would be as follows:

1. States: "Needs Attention", "Responded", "Done" [exclusive]
2a. Mine / All [sticky] [exclusive]
2b. Off-Topic, Escalated [sticky] [inclusive]
3. Sub states: "New", "Answer didn't help" [inclusive]

exclusive: only one of the states can be shown at a time.
inclusive: states can be freely combined. 
sticky: The selection is retained for the current session and beyond.
Flags: needinfo?(pmcclard)
Flags: needinfo?(mana)
Flags: needinfo?(bram)
Love the mock up Kadir.

Wouldn't "All" cover "Responded" and "Done" posts? Could we move those two states as filters of All?
Flags: needinfo?(pmcclard)
I think the intention is that "Mine" and "All" are orthogonal to "Attention Needed", "Responded" and "Done". Like this:

                       Mine                               |      All
                  ------------------------------------------------------------------------------------
Attention Needed | Attention needed that I am involved in | Any question that need attention          |
Responded        | Responded that I am involved in        | Any questions that have been responded to |
Done             | Finished questions I am involved in    | Any finished questions                    |
                  ------------------------------------------------------------------------------------

So there are really something like five axises that things can be filtered on: status (responded, done, etc), the sub-state (new, answer didn't help), my interaction, the escalated tag, and the off topic tag.
Yes, what Mike said. Of course it's debatable whether a global "mine" view would be useful. But I'd say it would only be useful in addition to showing it for the 3 areas separately. Since this way I can filter for things that need attention that I'm involved in. In that case I don't care about things that are done already or where I have posted last.

But thanks for bringing it up, Patrick. We should cleat that up before moving forward.
Of all the projects I’ve worked on so far, there was never a need to design any interface requiring five simultaneous axises to modify -- and I’ve worked on UIs meant for developers and administrators (ie. power users).

I’m not convinced that we need all five axises in order to achieve maximum productivity. Instead, having all of them present in the UI will make things confusing for almost everybody but the system designers.

So rather than proposing a solution outright, I’d like to present a thought:
Of the plethora of possible views, can we isolate a few that would be of great help to a majority of forum contributors, a majority of the time?

The main question we’d like to know is, does the primary division need to be along the line of mine/all, is it attention needed/responded/done, or is it new/answer didn’t help?

Perhaps a little survey of forum contributors workflow is in order.

For example, we might find that most contributors would like to see:
Mine, Attention needed, New, Not off-topic, Yes escalated

And then they’d like to see:
Mine, Attention needed, Answer didn’t help, No off-topic, Yes escalated

Then, for example, we know that the axis with the most impact is new/answer didn’t help. So there exist a possibility that sub-states is more important to our contributor’s productivity than status or my interaction.

Or maybe status is the most important thing. Or maybe my interaction vs. all interactions is the most important. We just need to know which one, or two.

The secondary question we’d like to know is highly related to the first: now that we know which axis is lower in priority, do we know which axis can be emphasized lower without a significant productivity hit? For example, do the escalated and off-topic tags get enough use by themselves to warrant an emphasized spot, or can they be hidden from view without too much impact on productivity? Repeat this with every other axis.

There is a possibility that a consensus on axis important isn’t reached. If so, we can provide an option for contributors to customize their views.

But my bet is that there exist a default view that will fit most people’s workflow most of the time, and where other views are prioritized according to the primary axis, then the secondary axis, then tertiary, etc.
Flags: needinfo?(bram)
Thanks, Bram. These are great points to bring up. I'm sure not all permutations of the 5 axises have the same importance, and maybe we can further simplify. 

Re: off-topic and escalated. The mockup doesn't make it clear unfortunately, but those selectors should absolutely not have the same emphasis as the top level statuses or even sub-statuses.

The discussion with contributors is happening here: https://support.mozilla.org/en-US/forums/contributors/709786?last=55446
Flags: needinfo?(mana)
reasons I think people go to forums:

- get answers from contributors (user knows this is an official mozilla site and trusts it)
- accidentally clicked to forums and found it useful
- contribute/answer questions
- referral (redirected from other page, friend, etc.)
- 


re: "approx 50% people are aware this is a forum"

education is key

- video for first time users presenting and educating about the forum/website
- form asking what the user wants, 1 question at a time, educating the user simultaneously while the form is filled. Once form is filled the user is either directed to the proper page or asked to submit a question.


for contributors, more templates are needed.

The forum could search while the user is typing the question and show similar questions/answers.
Jan, this time we are focused on making the questions listing work for contributor. We are assuming that the most important view for users is the question view and that is optimized for them. We'll be working on the user side of the question listing soon though, for those who don't come from emails, but from Google and want to browser the forum when Google didn't give them the right thread.

We did have some feedback from contributors in the meantime. I'll summarize that in the next post.
More templates should be added with search (for templates). Comment 0 from atopal makes good points.
Whiteboard: u=user c=questions p= s=2013.backlog → u=user c=questions p= s=2013.24
Estimated to 3pts during planning
Whiteboard: u=user c=questions p= s=2013.24 → u=user c=questions p=3 s=2013.24
Assignee: nobody → rdalal
Attached image Mine and All views
Regarding the axes discussion: There is not much to simplify really. We have the 3 states as axes (needs attention, responded, done) and the distinction between all threads and only those that I have posted in (mine and all). I'm not sure we can let go of an of these.

The only simplification I can see would come from combining the resulting 6 permutations, since they don't all have the same importance. I attached a mock-up where we combine all permutations for "threads I have posted in". We could just have a flat view, where we color code the 3 different states as background colors of the questions. 

I don't have a particular preference, but it seems to me like the overhead of two different representations is higher than keeping the interface consistent, even at the expense of dividing "my threads" into more sections that strictly necessary.

While we are discussing these implementations, we should keep in mind that all of this is driven by one goal: focusing attention on those threads that need our attention.
Flags: needinfo?(bram)
Madalina and I talked about this today and decided to go with the first mock-up. Bram, feel free to chime in, but we need to go ahead at this point and go live with one implementation, if we want to stand a chance of meeting our Q4 goal. We also need to push an implementation ASAP so we can fix issues that might come up, before we all leave for winter holidays.
Hi SUMO team, I have completely ran out of time this week to review this work. From a quick look-over, it looks good to me.

The way that we tell if this new interface is successful is twofold:

1. If new forum contributors can successfully use it without serious complaints. These filtering interface will have a learning curve, but hopefully it won’t be too high to discourage new contributors.

2. If our most active existing contributors (ie. power users) reports greater efficiency. Efficiency means time-saved, more questions answered, and faster response rate (so, for example, time to first answer marked as solved might be an interesting thing to measure).

I will carve out some time to take a closer look next week. Again, sorry for not being able to devote any time for this project!
Flags: needinfo?(bram)
Duplicate of this bug: 928902
Hi Bram, no worries, and thanks for the comments, those are great metrics to evaluate the success of this project. Our main goal when we started this was to raise the solved rate to at least 35% from a little less than 30% today. This interface should help in achieving that goal by allowing us to catch cases more easily where we were dropping the ball before (that equates to 7% of all threads today). Ideally those cases where we didn't respond to questions in the "needs attention" bucket should drop to zero. We have another project that should help us increase the solved rate by getting more people to tell us when proposed solutions didn't help (bug 928899).

Looking forward to more feedback from you!
Whiteboard: u=user c=questions p=3 s=2013.24 → u=user c=questions p=3 s=2013.24 [needsverify]
Attached file sumo - forum filters (obsolete) —
The feedback I have regarding the UI are twofold:


1. the New > Answer didn’t help > Needs info > Solution Provided > Solved > Locked flow should be conceptualized and displayed as a lifecycle or a progression that every forum question goes through, rather than an unordered list. This is so that every forum contributor can look for a particular “stage” that a question undergoes.

In the mockup, I’ve visualized the progression as a perfectly linear flow, but there’s no reason why it should be this way!

For example, here’s a less linear flow that might explain the forum lifecycle better.

     ┌─˃ Solution provided  ─┐
New ─├─˃ Answer didn’t help ─┤─˃ Solved ─˃ Locked
     └─˃ Needs info from OP ─┘

We can use the same arrowed boxes, but split it into three branches before converging again at the end.


2. Off topic and escalated should be conceptualized as some sort of a flag or something similar, so forum contributors can see that they can turn one, both or none of them on and off. In the mockup, I’ve visualized them as checkboxes.


Color-coding questions is a very good idea, although to do this, we probably want to switch our forum background so it’s white, and eliminate the noise background (or minimize it). White makes for a cleaner palate to have areas of color be distinct from but not clashing with each other.

You can see the Firefox release notes page for color and flag inspirations:
http://www.mozilla.org/en-US/firefox/26.0/releasenotes/
Attached image question-filters-1.png
Does this look okay?
Flags: needinfo?(a.topal)
Attached image question-filters-2.png
Showing the sub-statuses...
Attached image sumo - forum filters (obsolete) —
Your design looks great, Rehan!

The only thing I would do further is position the sub-statuses so that it looks more contextual to the currently selected status.
Attachment #8345711 - Attachment is obsolete: true
Thanks Bram, we actually changed the design. I just pushed it to stage:
https://support.allizom.org/en-US/questions

If you had any ideas for how to improve this visually I'd love to hear them!
Flags: needinfo?(bram)
Attached image sumo - forum filters
A few things:

* Use default values that will improve our goals. This means defaulting to the “Attention needed” tab, which we seem to do in the prototype already. But if we need to default to substatus “New” in addition to “Attention needed”, for example, feel free to do that.

* Replace the wording of substatus “All” with something that indicates nothing being applied. Remember, we already have “All questions” as a status, so to have another “All” substatus is confusing. What does “All” mean? Which one will show me absolutely everything? Which one will show me everything but in a specific context? A tweak in wording will help.

* The problem I am worried about that we need to solve is: how do we make it clear that the status, substatus and flags would apply to everything that exists on the page, rather than everything under the top white box only. How do we make the tab feel more overarching? The attached design tried to do this, but don’t think of it as prescriptive.
Attachment #8346153 - Attachment is obsolete: true
Flags: needinfo?(bram)
I landed a fix so that Needs Attention filter for last 7 days applies to updated column instead of created:
https://github.com/mozilla/kitsune/commit/86952017045af90ad9dea1800c4d2dfe658e9afd

BTW, this all landed and was deployed last night:
https://github.com/mozilla/kitsune/commit/8b4df993531d90b07ee8de37fafd170831c9a1eb

The pull request was here:
https://github.com/mozilla/kitsune/pull/1756
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 928902
Flags: needinfo?(a.topal)
You need to log in before you can comment on or make changes to this bug.