Follow up to Bug 914999 The phone of a contact exported to vCard does not appear when it has certain mobile type assigned

RESOLVED FIXED

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: isabelrios, Assigned: mai)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g-v1.2 fixed, b2g-v1.3 fixed)

Details

(Whiteboard: [u=commsapps-user c=contacts p=0])

Attachments

(1 attachment)

256 bytes, text/html
Jose Manuel Cantera
: review+
Details
(Reporter)

Description

4 years ago
10/21 v1.2 build:
Gecko-6412d0e
Gaia-1fd3153

STR
1. Create a contact in the contact list
Name: Contact
Last Name: Last
Phone Number: Type: Personal, Number: 123456789
2. Open contact settings and tap on Export
3. Select Memory Card and choose the contact just created
4. Connect the device to a pc and open the vCard stored in the memory card.

EXPECTED
The contact is shown with the information it has in the contact list.

ACTUAL
When the phone type is:
Personal
Fax Home
Fax Office
Fax Another
Another 

the contact's phone number is not exported correctly. When opening the vCard created, the phone field is empty.
If Mobile, Home or Work is selected, then the phone number is shown correctly.

*Reproduced so far with outlook, windows

Updated

4 years ago
Assignee: nobody → mri
(Assignee)

Comment 1

4 years ago
Created attachment 821011 [details]
patch v1.0

Please, could you review my code?
Regards
Attachment #821011 - Flags: review?(jmcf)
Not sure why this would be a blocker. The type is either mobile/ home/ work. As long as the display is correct for these types, I wouldn't block on this bug.
blocking-b2g: koi? → -
Flags: needinfo?(isabelrios)

Comment 3

4 years ago
(In reply to Preeti Raghunath(:Preeti) from comment #2)
> Not sure why this would be a blocker. The type is either mobile/ home/ work.
> As long as the display is correct for these types, I wouldn't block on this
> bug.

Tha'ts not true, the type can be any of the ones referenced in the bug report. I believe that's bad for the user. In any case we will ask for an approval

Updated

4 years ago
Attachment #821011 - Flags: review?(jmcf) → review+

Comment 4

4 years ago
https://github.com/mozilla-b2g/gaia/commit/397e06b63ab7f9941688f6d139135fbe5e992417
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

4 years ago
Comment on attachment 821011 [details]
patch v1.0

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment] 
When the users export their contacts to the sdcard, the contacts file contains wrong format information so the users cannot retrieve all the information when they import the contacts to other applications.
[Bug caused by] (feature/regressing bug #): Feature
[User impact] if declined: The users lost information when thet export theirs contacts to vcard format
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): The changed code has been tested and the code changes only affect this functionality.
[String changes made]:
Attachment #821011 - Flags: approval-gaia-v1.2?

Updated

4 years ago
Attachment #821011 - Flags: approval-gaia-v1.2? → approval-gaia-v1.2?(francisco.jordano)
Comment on attachment 821011 [details]
patch v1.0

Breaks a feature, since we wont save phones with types different than mobile, and the patch is not risky at all, just adding more types to the list of supported types.

a=me
Attachment #821011 - Flags: approval-gaia-v1.2?(francisco.jordano) → approval-gaia-v1.2+
(Reporter)

Comment 7

4 years ago
Removing ni as per comment 3, thanks
Flags: needinfo?(isabelrios)
Hi John,

Could you please help us with the uplift to v1.2 branch?. Thanks!
Flags: needinfo?(jhford)
[v1.2 2b35835] Merge pull request #13033 from gitmai/bug-928918-export-vcard-phonenumber
status-b2g-v1.2: --- → fixed
Flags: needinfo?(jhford)
(Assignee)

Comment 10

4 years ago
I can not see the changes of the pr #13033  on branch 1.2 and in the history doesn't appear the merge comment. Do you mind check if the merge was made?
Flags: needinfo?(jhford)
Not sure what happened here.

[v1.2 33f543f] Merge pull request #13033 from gitmai/bug-928918-export-vcard-phonenumber
Flags: needinfo?(jhford)
(Assignee)

Comment 12

4 years ago
Thank you very much!
(Reporter)

Comment 13

4 years ago
Checked on v1.2 (11/18 build):
Gecko-1443247
Gaia-7a23f8c

Now it also works with Personal, but still failing for:
Fax Home
Fax Office
Fax Another
Another 

Marina is already having a look at it.
(Assignee)

Comment 14

4 years ago
Hi, 
I thought the problem with outlook is how to make the field mapping. 
STR to view all of the mapped fields:
   In the open contact, go to the Contact tab, in the Show group, click All Fields. You can see a table with all fields.

The actual mapping is:
Contacs field      VCARD MAP                       OUTLOOK MAP
Fax Home       --> fax,home          -->        Home Fax 
Fax Office     --> fax,work          -->        Business Fax
Fax Another    --> fax,other         -->        Other Fax
Another        --> other             -->        Other Telephone Number

Kind regards
(Reporter)

Comment 15

4 years ago
The phone numbers appear as Marina said.

If it is confirmed that the actual mapping above is right, the bug could be verified.
status-b2g-v1.3: --- → fixed
You need to log in before you can comment on or make changes to this bug.