Closed Bug 928929 Opened 6 years ago Closed 6 years ago

Building with mozmake and PSEUDO_DERECURSE=no-pymake breaks in testing/mochitest/chrome/libs

Categories

(Firefox Build System :: General, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla27

People

(Reporter: Gijs, Assigned: glandium)

References

Details

Attachments

(1 file, 1 obsolete file)

"Mozilla tools directory: E:\mozilla-build\"
Visual C++ 9 Express directory: C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\
Visual C++ 10 Express directory: E:\VS2010\VC\
Visual C++ 11 directory: C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\
Visual C++ 11 Express directory: C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\
Windows SDK directory: C:\Program Files (x86)\Windows Kits\8.0\
Windows SDK version: 8.0
Setting environment for using Microsoft Visual Studio 2010 x86 tools.
Using the Windows 8.0 Developer Kit
Mozilla build environment: MSVC version 10.

$ ./mach clobber && ./mach build

...

26:54.00 e:/dev/ux-central/tools/quitter/chrome.manifest: WARNING: no preprocessor directives found
26:56.65 mozmake.EXE[5]: *** No rule to make target 'test-dir/', needed by 'libs'.  Stop.
26:56.65 e:/dev/ux-central/config/recurse.mk:99: recipe for target 'testing/mochitest/chrome/libs' failed
26:56.67 mozmake.EXE[4]: *** [testing/mochitest/chrome/libs] Error 2
26:56.67 e:/dev/ux-central/config/recurse.mk:39: recipe for target 'libs' failed
26:56.67 mozmake.EXE[3]: *** [libs] Error 2
26:56.67 e:/dev/ux-central/config/rules.mk:693: recipe for target 'default' failed
26:56.67 mozmake.EXE[2]: *** [default] Error 2
26:56.67 e:/dev/ux-central/client.mk:394: recipe for target 'realbuild' failed
26:56.67 mozmake.EXE[1]: *** [realbuild] Error 2
26:56.67 client.mk:179: recipe for target 'build' failed
26:56.67 mozmake.EXE: *** [build] Error 2
26:56.68 1016 compiler warnings present.


$ cat $MOZCONFIG
export MOZ_PSEUDO_DERECURSE=no-pymake

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../builds/ux-@CONFIG_GUESS@

ac_add_options --enable-profiling



:-(
Blocks: 926332
Just got this on a pull from this morning. Things were working end of last week.
Attached patch fix build error on Windows, (obsolete) — Splinter Review
This seems to work.
Attachment #819800 - Flags: review?(mh+mozilla)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 819800 [details] [diff] [review]
fix build error on Windows,

Review of attachment 819800 [details] [diff] [review]:
-----------------------------------------------------------------

I'd rather take on the occasion to kill the local rule.
Attachment #819800 - Flags: review?(mh+mozilla) → review-
Assignee: gijskruitbosch+bugs → mh+mozilla
Duplicate of this bug: 929304
Attachment #820028 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/76d57823adef
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.