Closed Bug 928954 Opened 8 years ago Closed 8 years ago

contacts import from sim broken by webidl

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bkelly, Assigned: bkelly)

References

Details

(Whiteboard: [c= p=1 s= u=][xfail][fromAutomation])

Attachments

(1 file)

The import of contacts from sim card has broken with the recent changes to use webidl in mozContacts.

E/GeckoConsole(  532): [JavaScript Error: "TypeError: Argument 1 of ContactManager.save does not implement interface
 mozContact." {file: "app://communications.gaiamobile.org/contacts/js/utilities/import_sim_contacts.js" line: 184}]
Whiteboard: [c= p=1 s= u=] → [c= p=1 s= u=][xfail]
Comment on attachment 819751 [details]
Pull request at https://github.com/mozilla-b2g/gaia/pull/12982

This PR solves the problem with the sim import.

While trying this on the phone, was working, I realised about bug 929043, so let's land this and work on the next one.

Thanks Ben!
Attachment #819751 - Flags: review?(francisco.jordano) → review+
Sounds good.  Thanks!  Merged:

  https://github.com/mozilla-b2g/gaia/commit/595ee85a2d7f16b72b3eef882df5b9a54e885480

Leaving open for xfail at the moment.
Duplicate of this bug: 928882
Blocks: 928407
Whiteboard: [c= p=1 s= u=][xfail] → [c= p=1 s= u=][xfail][fromAutomation]
Depends on: 929078
Tests re-enabled.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.