Closed Bug 928968 Opened 7 years ago Closed 7 years ago

Add a command to the gaia command line tool to print the applications installed

Categories

(Firefox OS Graveyard :: Gaia, defect)

defect
Not set
normal

Tracking

(firefox29 fixed, b2g-v1.2 fixed)

RESOLVED FIXED
Tracking Status
firefox29 --- fixed
b2g-v1.2 --- fixed

People

(Reporter: nebelhom, Assigned: davehunt)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130911164256

Steps to reproduce:

I think it would be a very useful feature to add a command in gcli that lists all the applications installed.
I already have a patch that does this (it was useful for investigating an issue), but think we should probably wait for the outcome of bug 921939 before proceeding. Ideally we could add a command to gaiatest that then allows other tools to output this list, such as b2gperf to help someone discover the available applications.
Depends on: 921939
Assignee: nobody → dave.hunt
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8343042 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14402

This patch adds an installed_apps property to GaiaApps and a listallapps command to gcli. Also modified the runningApps method to be a property and return a list of GaiaApp objects. I have updated all places this method is called, and checked that it's not used in any package (that I'm aware of) that depends on gaiatest.

Output looks like:

$ gcli listallapps
1: Browser
2: Calendar
3: Camera
...

$ gcli listrunningapps
1: Homescreen
2: Messages
3: Phone
...
Attachment #8343042 - Flags: review?(zcampbell)
Attachment #8343042 - Flags: feedback?(mozilla_dev)
Comment on attachment 8343042 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14402

Rob: This patch includes a change to an endurance test. I've tested it successfully locally, but would appreciate your review. Thanks.
Attachment #8343042 - Flags: review?(rwood)
Comment on attachment 8343042 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14402

Looks great, thanks for updating the endurance test Dave, appreciated.
Attachment #8343042 - Flags: review?(rwood) → review+
:davehunt

Having looked over the code, it looks fine to me. I can't find anything, but Travis-Ci is unhappy though...

(In reply to Dave Hunt (:davehunt) from comment #3)
> Comment on attachment 8343042 [details]
> Pointer to Github pull request:
> https://github.com/mozilla-b2g/gaia/pull/14402
> 
> This patch adds an installed_apps property to GaiaApps and a listallapps
> command to gcli. Also modified the runningApps method to be a property and
> return a list of GaiaApp objects. I have updated all places this method is
> called, and checked that it's not used in any package (that I'm aware of)
> that depends on gaiatest.
> 
> Output looks like:
> 
> $ gcli listallapps
> 1: Browser
> 2: Calendar
> 3: Camera
> ...
> 
> $ gcli listrunningapps
> 1: Homescreen
> 2: Messages
> 3: Phone
> ...
(In reply to Johannes Vogel (:nebelhom) from comment #6)
> Having looked over the code, it looks fine to me. I can't find anything, but
> Travis-CI is unhappy though...

The Travis-CI failure is a known intermittent. I've retriggered it but this failure doesn't concern me for this patch.
Comment on attachment 8343042 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14402

r+ this could be useful in the future, thanks.
Attachment #8343042 - Flags: review?(zcampbell) → review+
Comment on attachment 8343042 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/14402

Johannes gave feedback in comment 6.
Attachment #8343042 - Flags: feedback?(mozilla_dev) → feedback+
You need to log in before you can comment on or make changes to this bug.