B2G Desktop should use a tcp socket

RESOLVED DUPLICATE of bug 942756

Status

Firefox OS
Simulator
P1
normal
RESOLVED DUPLICATE of bug 942756
5 years ago
4 years ago

People

(Reporter: paul, Assigned: paul)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Enabling the remote debugger in B2G Desktop will open a unix socket. The App Manager doesn't support unix sockets. And unix sockets don't work everywhere (Windows).

B2G Desktop should use a tcp socket.
(Assignee)

Updated

5 years ago
Priority: -- → P1
That's a B2G bug, we should use a ifdef over here:
  http://mxr.mozilla.org/mozilla-central/source/b2g/app/b2g.js#808

And set devtools.debugger.unix-domain-socket to 6000 ifndef MOZ_WIDGET_GONK
(Assignee)

Updated

5 years ago
Blocks: 932758
(Assignee)

Updated

5 years ago
Assignee: nobody → paul
(Assignee)

Comment 2

5 years ago
Created attachment 8340331 [details] [diff] [review]
v1
Attachment #8340331 - Flags: feedback?(poirot.alex)
(Assignee)

Updated

4 years ago
Blocks: 942756
(Assignee)

Updated

4 years ago
No longer blocks: 942756
Depends on: 942756
Comment on attachment 8340331 [details] [diff] [review]
v1

Looks like it will be fixed in bug 942756
Attachment #8340331 - Flags: feedback?(poirot.alex)
(Assignee)

Updated

4 years ago
Component: Developer Tools: App Manager → Simulator
Product: Firefox → Firefox OS
Version: Trunk → unspecified
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 942756
You need to log in before you can comment on or make changes to this bug.