toLocaleFormat does not support %Oe and %Od in Windows

RESOLVED DUPLICATE of bug 818634

Status

()

defect
RESOLVED DUPLICATE of bug 818634
6 years ago
2 years ago

People

(Reporter: lapsap7+mz, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

1. Run the following code inside JS console:
   var date =  new Date(2013, 9, 5, 6)
   date.toLocaleFormat("%B %Oe")
   date.toLocaleFormat("%B %Od")


Actual results:

"Sat Oct 05 2013 06:00:00 GMT+0200 (Romance Standard Time)"
"Sat Oct 05 2013 06:00:00 GMT+0200 (Romance Standard Time)"


Expected results:

According to
https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Date/toLocaleFormat
and
http://pubs.opengroup.org/onlinepubs/007908799/xsh/strftime.html

For en-US regional settings, expected results are:
  "October 5"
  "October 05"

For Chinese regional settings, expected results are:
  "十月五日"
  "十月 五日" (there is a full-width space U+3000)
toLocaleFormat was removed in bug 818634.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818634
You need to log in before you can comment on or make changes to this bug.