Closed Bug 929063 Opened 6 years ago Closed 6 years ago

Twitter layout broken/missing items

Categories

(Firefox :: General, defect, critical)

25 Branch
x86
All
defect
Not set
critical

Tracking

()

VERIFIED FIXED
Firefox 27
Tracking Status
firefox24 --- unaffected
firefox25 --- verified
firefox26 --- verified
firefox27 --- verified
firefox-esr17 --- unaffected
firefox-esr24 --- unaffected

People

(Reporter: cww, Assigned: keeler)

References

Details

Attachments

(1 file)

From Input, reports of layout broken (possible missing images and stylesheets) specific to today's Firefox 25 beta release:

* firefox 25.0.0 on Windows 7 <http://twitter.com/>
Twitter's landing page is no longer displaying correctly in Firefox 25.0.  It does render correctly in IE.

* firefox 24.0.0 on Windows XP <>
there are dangerous adds on Twitter main page

* firefox 25.0.0 on Windows 7 <>
Twitter cannot display pics or do any links. Works perfectly fine on IE, but after trying to clear cookies and everything else I can do I still have the same problems. 

* firefox 25.0.0 on Windows 8 <https://www.tumblr.com/>
Hello! I've been having some problems with some websites like Tumblr, Twitter, Youtube and Facebook. Every hour I have to clean cache so the website can look normal. Right now, even if I do that, everything looks bad and I just cant even log in... My computer has Windows 8, and Firefox, even with some problems like these ones, is the one that works better here.

* firefox 25.0.0 on Windows 7 <https://twitter.com/>
The Twitter website is not formatting properly. 

* firefox 25.0.0 on Windows 7 <http://twitter.com/>
Issue with twitter.  Not displaying properly.

* firefox 25.0.0 on Windows 7 <https://twitter.com/>
Bad rendering of twitter page.

* firefox 25.0.0 on OS X <http://twimg.com/>
Twitter not displaying images from:

Secure Connection Failed

An error occurred during a connection to si0.twimg.com. The OCSP response contains out-of-date information. (Error code: sec_error_ocsp_old_response)

    The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
    Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.

* firefox 25.0.0 on Windows 7 <https://twitter.com/>
When loading the Twitter website, the stylesheets do not load for some reason. I'm left with the display as if I'd went to "View" > "Page style" > "No style". Double checking, I do not have this setting applied. Twitter website currently works fine on other browsers.

* firefox 25.0.0 on Windows 7 <>
the twitter is weird right now

* firefox 25.0.0 on Windows 7 <>
21/10/2013-both twitter and tumblr pages will not load correctly, cannot load log in for tumblr and twitter loads as a html page only 

* firefox 25.0.0 on OS X <https://twitter.com/>
Firefox 25b9 broke the twitter layout.
I've been able to reproduce on all FF25 betas, and not in FF24 on Mac OS X. This appears to be a regression caused by a combination of a FF25 change, and a very recent Twitter change.
David, is this related to bug 928832 and bug 914034?
Flags: needinfo?(dkeeler)
Appears to be fixed on the latest Nightly.
Please work with ashughes to find a tighter regression/progression window, if need be.
(In reply to Alex Keybl [:akeybl] from comment #2)
> David, is this related to bug 928832 and bug 914034?

I think so. As far as I can tell, here's what's happening:

For FF25, twitter/tumblr are stapling OCSP responses with their certificates (specifically for si0.twimg.com and secure.assets.tumblr.com). However, these responses expired yesterday, and when we fail to verify the response, we kill the connection.

For FF26, these servers are not stapling an OCSP response. We fetch the certificate status ourselves, and the responder sends a recent response. Thus, the connection continues.
Empty comment to clear needinfo.
... and I did exactly the wrong thing. Apologies for the bugspam.
Flags: needinfo?(dkeeler)
(In reply to David Keeler (:keeler) from comment #5)
> (In reply to Alex Keybl [:akeybl] from comment #2)
> > David, is this related to bug 928832 and bug 914034?
> 
> I think so.

David do you still need a regression window here or are you confident you can fix it with the information provided?
This screenshot provided as per :Cww's instructions.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #8)
> (In reply to David Keeler (:keeler) from comment #5)
> > (In reply to Alex Keybl [:akeybl] from comment #2)
> > > David, is this related to bug 928832 and bug 914034?
> > 
> > I think so.
> 
> David do you still need a regression window here or are you confident you
> can fix it with the information provided?

I think I've got a handle on it - if uplifting bug 914034 fixes this, then we're all set.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #8)
> (In reply to David Keeler (:keeler) from comment #5)
> > (In reply to Alex Keybl [:akeybl] from comment #2)
> > > David, is this related to bug 928832 and bug 914034?
> > 
> > I think so.
> 
> David do you still need a regression window here or are you confident you
> can fix it with the information provided?

That's finding out too late, please continue ensuring the progression window identified is correct (bug 914034 on m-c).
Flags: needinfo?(anthony.s.hughes)
Keywords: qawanted
Tracy confirmed over on bug 914034 that this issue (and bug 928832) is resolved on Nightly after the landing of the fix for bug 914034. Alex, does that give you enough confidence or do you need something more?
Flags: needinfo?(anthony.s.hughes)
Keywords: qawanted
yep, all good now thanks ashughes
Duplicate of this bug: 929300
Fixed as per bug 914034 comment 3.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Assignee: nobody → dkeeler
Depends on: 914034
Target Milestone: --- → Firefox 27
You need to log in before you can comment on or make changes to this bug.