Canceling a download from the Downloads Panel sometimes pauses it instead

RESOLVED FIXED in mozilla30

Status

()

defect
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Paolo, Assigned: Paolo)

Tracking

(Blocks 1 bug)

Trunk
mozilla30
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This was observed in bug 922137:

- Download http://www.softpedia.com/dyn-postdownload.php?p=84329&t=4&i=1
- Cancel the download from the Downloads Panel
- Restart the download, then cancel it again

Sometimes, the download goes to the "paused" state instead of the "canceled" state.
Posted patch The patchSplinter Review
This was caused by a race condition in the functions that handle asynchronous progress updates, that set hasPartialData to true again after it had been cleared by removePartialData.
Assignee: nobody → paolo.mozmail
Status: NEW → ASSIGNED
Attachment #8335599 - Flags: review?(enndeakin)
Attachment #8335599 - Flags: review?(enndeakin) → review+
https://hg.mozilla.org/mozilla-central/rev/8d1664e48b59
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.