Closed Bug 929106 Opened 7 years ago Closed 7 years ago

Pressing "stop" to kill an app on the device doesn't do anything with FFOS 1.3

Categories

(DevTools Graveyard :: WebIDE, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 28

People

(Reporter: jlong, Assigned: ochameau)

References

Details

I'm using Nightly 2013-10-19, and Firefox OS 1.3.0.0-prerelease. If I connect the App Manager to my device, and install a packaged app from my computer (just a simple demo app), and launch it by pressing  "start", I can't kill it by pressing "stop".

The "stop" button doesn't seem to do anything. No errors in the browser console, adb logcat, or anything.

I downgraded my device to 1.2, and it *does* work, so it's the fault of 1.3.
My device is a Geeksphone Peak.
It works on the 1.3 Simulator from 2013-09-29, so either the issue is device specific, or it broke between 9-29 and 10-19.
Priority: -- → P1
Duplicate of this bug: 933283
Assignee: nobody → poirot.alex
Depends on: 933380
Fixed by bug 933380.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Keywords: verifyme
Verified on Aurora 28.0a2 on Win 7 64-bit and Mac 10.9.
The apps are stopped if Simulator 1.2, 1.3 or B2G 1.2.0.0-prerelease unagi device are used.

On an unagi device with Firefox OS 1.3.0.0-prerelease version, the apps can be stopped only if they were opened before connecting the device to computer. 
Pressing Start will open the app on the device, but the app is not updated with Debug / Stop in the App Manager page. 

Should I file a new bug for this issue? Thank you
Flags: needinfo?(poirot.alex)
It may be related to bug 966988. Could you open a bug if that still occurs once it lands?
(that patch targets the device, not firefox)
Flags: needinfo?(poirot.alex)
The issue described in comment 5 is still reproducible (bug 966988 landed), I've filed bug 970231.

On the other hand, the issue described in this bug is now fixed, I'm removing the verifyme keyword.
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: petruta.rasa
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.