bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Remove all obsolete crontabber code related to storing the state in a json file

RESOLVED FIXED in 78

Status

Socorro
General
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: peterbe, Assigned: peterbe)

Tracking

unspecified
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

5 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=928048 changes to store the state in Postgres instead but because that bug needs to involve a migration for existing systems the old APIs related to reading from a JSON file is still left in the code.

All code related to JSON (including the migration) can be removed.
(Assignee)

Updated

5 years ago
Assignee: nobody → peterbe
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Depends on: 950735

Comment 2

4 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/f9ff06762f64b7172c30be841a97eda6e6d060f9
fixes bug 929204 - Remove all obsolete crontabber code related to storing the state in a json file

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Target Milestone: --- → 78
(Assignee)

Updated

4 years ago
Duplicate of this bug: 909407
You need to log in before you can comment on or make changes to this bug.