[Helix] [1.1 HD] unable to send file to another device via BT

RESOLVED INVALID

Status

Firefox OS
Bluetooth
--
major
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 820082 [details]
logcat

I can receive but i cannot send files out via Bluetooth.   In my case, i'm just trying to send out a simple jpeg to my macbookpro.   i can receive incoming successfully.

full logcat and screenshot attached.  

Logcat snippet:
**************
03-01 19:35:03.999: I/Gonk(160): dbus_func_args_timeout_valist: D-Bus error in GetServiceAttributeValue: org.bluez.Error.Failed (GetServiceAttribute Failed)
03-01 19:35:03.999: I/abtfilt(434): BT Action
03-01 19:35:03.999: I/abtfilt(434): WMI Cmd: 145 Len: 16
03-01 19:35:03.999: E/abtfilt(434): [Abf_WlanDispatchIO] send WMI command (cmd:0x9, size:16) call failed!
03-01 19:35:03.999: E/abtfilt(434): Last Error: Operation not permitted
03-01 19:35:03.999: E/abtfilt(434): [ExecuteBtAction] BT Action issue failed, Ioctl: 0x9, Len: 12
03-01 19:35:03.999: E/abtfilt(434): Last Error: Operation not permitted
03-01 19:35:03.999: I/abtfilt(425): BT Action
03-01 19:35:03.999: I/abtfilt(425): WMI Cmd: 145 Len: 16
03-01 19:35:04.859: I/IdleService(160): Get idle time: time since reset 899 msec
03-01 19:35:04.859: I/IdleService(160): Idle timer callback: current idle time 899 msec
03-01 19:35:04.859: I/IdleService(160): next timeout 99 msec from now
03-01 19:35:04.859: I/IdleService(160): SetTimerExpiryIfBefore: next timeout 98 msec from now
03-01 19:35:04.869: I/IdleService(160): reset timer expiry to 106 msec from now
03-01 19:35:04.969: I/IdleService(160): Get idle time: time since reset 1011 msec
03-01 19:35:04.969: I/IdleService(160): Idle timer callback: current idle time 1011 msec
03-01 19:35:04.969: I/IdleService(160): next timeout 4294967293987 msec from now
03-01 19:35:04.979: I/IdleService(160): SetTimerExpiryIfBefore: next timeout 4294967293987 msec from now
03-01 19:35:04.979: I/IdleService(160): reset timer expiry to 4294967293995 msec from now
03-01 19:35:04.979: I/IdleService(160): Idle timer callback: tell observer 48736f10 user is idle
03-01 19:35:04.979: I/IdleService(160): Get idle time: time since reset 1017 msec
03-01 19:35:05.109: I/Gonk(160): Setting nice for pid 3294 to 18
03-01 19:35:05.109: I/Gonk(160): Changed nice for pid 3294 from 0 to 18.
03-01 19:35:05.359: E/profiler(3294): Registering start signal
03-01 19:35:05.469: I/abtfilt(434): BT Action
03-01 19:35:05.469: I/abtfilt(434): WMI Cmd: 145 Len: 16
03-01 19:35:05.469: E/abtfilt(434): [Abf_WlanDispatchIO] send WMI command (cmd:0x9, size:16) call failed!
03-01 19:35:05.469: E/abtfilt(434): Last Error: Operation not permitted
03-01 19:35:05.469: E/abtfilt(434): [ExecuteBtAction] BT Action issue failed, Ioctl: 0x9, Len: 12
03-01 19:35:05.469: E/abtfilt(434): Last Error: Operation not permitted

Repro:
1) install Helix partner build 20131016180525
2) pair the device via BT to another device (i used a mac book pro)
3) launch gallery, and try to share a device via bluetooth transfer
4) Verify it fails to transfer the file via BT

Expected:
- file transfers correctly
(Reporter)

Comment 1

5 years ago
Created attachment 820083 [details]
screenshot
Hi Tony,

The first thing came up to my mind is "Bluetooth Sharing" was not enabled on your MBP. Would you mind checking it? (See point 5 of FAQ for more information, https://wiki.mozilla.org/B2G/Bluetooth).

I've also asked for Walter's help to test again and see if we can reproduce.
Flags: needinfo?(tchung)
Flags: needinfo?(wachen)
20131015042201 partner helix build works fine for me.
pairing, receiving and sending are okay.

Just one interesting question.
I only got the 10/15 partner build.
Where can I get the 10/16 build?

Did you shallow flash gecko and gaia of Mozilla build?
Or, did you flash the whole package in?
Flags: needinfo?(wachen)
(Reporter)

Comment 4

5 years ago
(In reply to Walter Chen[:ypwalter][:wachen] from comment #3)
> 20131015042201 partner helix build works fine for me.
> pairing, receiving and sending are okay.
> 
> Just one interesting question.
> I only got the 10/15 partner build.
> Where can I get the 10/16 build?

I got the build from the Helix wiki, stating 20131015 image. 

when i ran checkversions.sh, its returning:
Gaia:     4afe209fb0d5c0e03d655a4e900ab8f13ca8fb4a
Gecko:   
BuildID   20131016180525
Version   18.0

> 
> Did you shallow flash gecko and gaia of Mozilla build?
> Or, did you flash the whole package in?

nope, just flashed update.app via the huawei flashing tool.   this is the straight partner image.

(In reply to Eric Chou [:ericchou] [:echou] from comment #2)
> Hi Tony,
> 
> The first thing came up to my mind is "Bluetooth Sharing" was not enabled on
> your MBP. Would you mind checking it? (See point 5 of FAQ for more
> information, https://wiki.mozilla.org/B2G/Bluetooth).
> 
> I've also asked for Walter's help to test again and see if we can reproduce.

oops, that was it!  thanks Eric and Walter.  marking this bug invalid.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(tchung)
Resolution: --- → INVALID
No problem. However, it is still really interesting.
R u using engineer build or user build?

Updated

5 years ago
blocking-b2g: hd? → ---
You need to log in before you can comment on or make changes to this bug.