Closed Bug 929369 Opened 6 years ago Closed 2 years ago

[Flatfish][System] Make value selector dialogs not fill full screen

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: gasolin, Unassigned)

References

Details

(Whiteboard: [flatfish][TCP=polish])

Attachments

(5 files)

Make value selector dialogs not fill full screen, have modal dialog instead
Blocks: flatfish
Blocks: 935816
expect:

UItest/UI/Select items shown in dialog
hi Fred,

is it possible to have someone to deal with this bug?
blocking-b2g: --- → 1.3+
Flags: needinfo?(gasolin)
Whiteboard: [Flatfish only][developer+]
Value selector dialogs contains bunch of dialogs and a bit complicated. I'll work on it, but it needs time
Flags: needinfo?(gasolin)
blocking-b2g: 1.3+ → ---
Assignee: nobody → gasolin
Attached image UI spec
WIP, will send review after bug 941552 and bug 936401
Depends on: 941552, 936401
Blocks: 940922
Blocks: 940921
Attached image multi-select screenshot
Comment on attachment 8336599 [details] [review]
pull request redirect to github

this patch applied for single and multiple selection, not affect date and time selectors
Attachment #8336599 - Flags: review?(alive)
Comment on attachment 8336599 [details] [review]
pull request redirect to github

redirect review to rudy
Attachment #8336599 - Flags: review?(alive) → review?(rlu)
Comment on attachment 8336599 [details] [review]
pull request redirect to github

r+ for this almost CSS-only change.
Fred, thank you.
Attachment #8336599 - Flags: review?(rlu) → review+
merged in gaia-master https://github.com/mozilla-b2g/gaia/commit/616f689484c17b8bd724873c52485dd5a4a29119

thanks!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Depends on: 942902
Reverted because this bug caused bug 942902

[master bd8053d] Revert "Merge pull request #13940 from gasolin/issue-929369"
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Hi arnau, I add the generic-dialog from system to inherit some styles, and some of its style cause the phone regression behavior.

So I added a patch for it, can you help feedback if this cause any side effect on phone?

 form[role="dialog"][data-type="value-selector"].generic-dialog:before
Attachment #8338193 - Flags: feedback?(arnau)
Fred, Paco has been working on a tablet version for all modals in gaia.
Could you please check:
https://github.com/pacorampas/gaia/compare/bb-modals-tablet
Cool, I'll take a look on it. Thanks
In gaia we have a convention tablet media-query size to 768 https://github.com/gasolin/gaia/blob/master/shared/js/screen_layout.js#L23

The size is also chosen by bootstrap. Please use the same convention value because vender might replace the threshold via build script.
Flags: needinfo?(arnau)
Blocks: flatfish-ux
No longer blocks: flatfish
I'm cancelling all old Flatfish ni and reviews till we have final specs.
Feel free to ping me again.
Flags: needinfo?(rnowmrch)
Whiteboard: [Flatfish only][developer+] → [flatfish][TCP]
resigned since it's not been determined.
Assignee: gasolin → nobody
Whiteboard: [flatfish][TCP] → [flatfish][TCP=polish]
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 6 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.