--disable-webm build fails with "dist/include/OggReader.h:14:26: fatal error: vorbis/codec.h: No such file or directory" from DecoderTraits.cpp

RESOLVED FIXED in mozilla27

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dholbert, Assigned: rillian)

Tracking

Trunk
mozilla27
x86_64
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I can't build with these .mozconfig options:
{
ac_add_options --enable-debug --disable-optimize
ac_add_options --disable-webm
}

My build fails partway through, with this error:
{
/mozilla-central/content/media/DecoderTraits.cpp:18:0:
../../dist/include/OggReader.h:14:26: fatal error: vorbis/codec.h: No such file or directory
  #include <vorbis/codec.h>
                           ^
}

This is the converse of bug 928530 (which is about a build failure with --disable-ogg).  *That* bug makes a little more sense (sure, our webm code requires ogg support in order to build), but this bug here makes less sense (...does our ogg code really require webm support in order to build?)
Summary: --disable-webm build fails with "OggReader.h:14:26: fatal error: vorbis/codec.h: No such file or directory" from DecoderTraits.cpp → --disable-webm build fails with "dist/include/OggReader.h:14:26: fatal error: vorbis/codec.h: No such file or directory" from DecoderTraits.cpp
(This is with GCC 4.8 on Ubuntu 13.10, though it's unlikely that matters.)
See Also: → 928530
webm requires vorbis which requires ogg except on arm. I'll add an error for this as part of bug 928530.
Depends on: 928530
This should fix the ogg-depending-on-webm issue. The problem was we were only enabling the vorbis codec based on the webm switch, not on the ogg switch. This patch enables it based on either.
Assignee: nobody → giles
Status: NEW → ASSIGNED
Attachment #820417 - Flags: review?(ted)
Attachment #820417 - Flags: review?(ted) → review+
https://hg.mozilla.org/mozilla-central/rev/1fde59e2a706
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Duplicate of this bug: 819683
You need to log in before you can comment on or make changes to this bug.