./mach build binaries doesn't know that libucvja_s.a.desc is linked into libxul

RESOLVED DUPLICATE of bug 928204

Status

Firefox Build System
General
RESOLVED DUPLICATE of bug 928204
5 years ago
5 months ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 820323 [details]
objdir/toolkit/library/.deps/XUL.pp

$ touch intl/uconv/ucvja/UnifiedUCVJA.cpp 
$ ./mach build binaries
 0:00.21 /usr/bin/make -j8 -s binaries
 0:01.33 From ./dist/public: Kept 0 existing; Added/updated 0; Removed 0 files and 1 directories.
 0:01.34 From ./dist/sdk: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:01.36 From ./dist/private: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:01.51 From ./dist/idl: Kept 1156 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:02.14 From ./dist/include: Kept 3545 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:02.52 From ./dist/bin: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:04.55 From _tests: Kept 11444 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:05.10 UnifiedUCVJA.o
 0:05.48 libucvja_s.a.desc
Your build was successful!
Please attach objdir/binary-deps.mk.
(Reporter)

Comment 2

5 years ago
Created attachment 820360 [details]
objdir/binaries-deps.mk
I think you are victim of bug 928204.
Does running mach build binaries again after it rebuilds libucvja_s.a.desc rebuilds XUL ?
(Reporter)

Comment 5

5 years ago
(In reply to comment #4)
> Does running mach build binaries again after it rebuilds libucvja_s.a.desc
> rebuilds XUL ?

Nope:

$ ./mach build binaries
 0:00.24 /usr/bin/make -j8 -s binaries
 0:01.48 From ./dist/public: Kept 0 existing; Added/updated 0; Removed 0 files and 1 directories.
 0:01.49 From ./dist/sdk: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:01.51 From ./dist/private: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:01.67 From ./dist/bin: Kept 0 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:01.86 From ./dist/idl: Kept 1156 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:02.06 From ./dist/include: Kept 3545 existing; Added/updated 0; Removed 0 files and 0 directories.
 0:05.60 From _tests: Kept 11444 existing; Added/updated 0; Removed 0 files and 0 directories.
Your build was successful!
This is definitely bug 928204. I could reproduce and the patch from there fixes it (requires a plain mach build first)

(In reply to Mike Hommey [:glandium] from comment #4)
> Does running mach build binaries again after it rebuilds libucvja_s.a.desc
> rebuilds XUL ?

Since it was toolkit/library/binaries that was broken, that required a mach build to fixup, not mach build binaries.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 928204
Created attachment 8344476 [details] [diff] [review]
Finish to kill BOTH_MANIFESTS.
Comment on attachment 8344476 [details] [diff] [review]
Finish to kill BOTH_MANIFESTS.

Wrong bug
Attachment #8344476 - Attachment is obsolete: true

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.