If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow running just one test from a suite in Zippy

RESOLVED FIXED in 2013-10-28

Status

Marketplace
Payments/Refunds
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: scolville, Assigned: scolville)

Tracking

2013-10-28
x86
Mac OS X
Points:
---

Details

(Whiteboard: [qa-])

Comment hidden (empty)
Target Milestone: --- → 2013-10-28
I think if we re-write sellers.test.js to use supertest then we could get rid of runtests.js (no need for a test server) and we could put the nodeunit task back in the grunt file. That might give us some more features like running one file but I'm not sure.
Ah, looks like David added a way to send test file args.

https://github.com/mozilla/zippy/commit/f9bd2e51f98c2e112a0fc5b5bf252f5fde5b7a20
Assignee: scolville → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 929458
This isn't a dupe - David added running a single test suite. This adds running a single test within a suite.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
https://github.com/mozilla/zippy/commit/02b027e784e05862df13cec724f370f2ee5d86c3
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(In reply to Kumar McMillan [:kumar] from comment #1)
> I think if we re-write sellers.test.js to use supertest then we could get
> rid of runtests.js (no need for a test server) and we could put the nodeunit
> task back in the grunt file. That might give us some more features like
> running one file but I'm not sure.

Yes, if we can do that then that's cool - we should be able to maintain the same grunt args anyway. The main thing to note is if we use the grunt reporter it has very limited support for all the nodeunit reporter features e.g. testspec which is what allows running a single test within a suite. So if this gets refactored we need to avoid using the grunt reporter.
Assignee: nobody → scolville

Comment 6

4 years ago
Can you please add some STRs to this bug or mark it as [qa-] ?
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.