Sorting by Device lists only '(Unknown)' under device types

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
P3
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: krupa, Assigned: Keir Kettle)

Tracking

Points:
---

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 820683 [details]
screenshot

steps to reproduce:
1. Load https://mozilla.bango.com/mt/finance/revenue/?packageid=928315
2. In the table, from the dropdown box, select 'Device'

Currently the only device type being listed is (Unknown). We should either show valid/useful info about devices (keon, zte etc Or at least Android/Firefox OS) or disable this option until we have relevant info.

Comment 1

4 years ago
This is because we are not receiving useful user-agent information from you. In order for us to process the correct data we must receive more than just "blank device detail"

Comment 2

4 years ago
(In reply to Tom from comment #1)
> This is because we are not receiving useful user-agent information from you.
> In order for us to process the correct data we must receive more than just
> "blank device detail"

Is that data sent in a specific API or is it something that you read from the browser when we load the Bango screens?

Comment 3

4 years ago
Bango checking their Database to see if they are getting the User-Agent data and if so whether they can use it
Priority: -- → P3

Comment 4

4 years ago
Its two issues here.
One is our detection
we are not detecting some instances where they are sending us device information.
We'll get this fixed for 2nd week in November
This affects the alcaltel 4012x and lg-d300

in all other instances, the second issue applies

we are not getting useful device info from the Useragent
we have a useragent of the following:
Mozilla/5.0 (Mobile; rv:26.0) Gecko/26.0 Firefox/26.0
and that does not tell us the devices

what we would need is something like:
Mozilla/5.0 (Mobile; LG-D300; rv:18.1) Gecko/18.1 Firefox/18.1

and that will be fixed once we've sorted out our issue

Comment 5

4 years ago
We'll get a bunch of user agent strings that don't include the device, I don't think there's much Bango can do about that apart from processing what it gets. Things like Android the simulator and so on won't pass the device.

Once the alcatel and lg get added, let's close the issue.

Comment 6

4 years ago
Still on track.

Comment 7

4 years ago
this is being tested at present. Will confirm once fixed.

Comment 8

4 years ago
Uploaded to LIVE today.

Please close this bug.
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.