If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Composition Window Launched from a mailto; Link in a Web Browser Fails to Fill-in To: Address

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: David E. Ross, Unassigned)

Tracking

24 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPME Bug 913493 ?)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
At <http://campaign.r20.constantcontact.com/render?llr=9th5sujab&v=001g7xYn3eIW2MhNIW0Xnv-Caxhe-63bhDTumzmhfVkPtHlvo4Ve5zDQtf3Ynq7vuE3-8-X-IWyBih7wo3vn6hXERU17tv8F1giJ4s0lJHgXoU%3D>, there is a mailto link at the bottom of the Web page.  Selecting the link launches a compose window in Thunderbird.  The compose window has my From: and Reply-To: address (both the same), but the To: address is blank.  

The mailto: link is <mailto:info@hoganfoundation.org>.

Comment 1

4 years ago
Works fine for me (TB 24.0.1 on Windows 7).
(Reporter)

Comment 2

4 years ago
Windows 7 (x64)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.0.1

1.  Launch Thunderbird in Safe Mode.  

2.  Launch a browser for which Thunderbird is the default E-mail client.  

3.  Go to <http://www.latimes.com/>.  

4.  Select any news story that ends with a mailto link to the reporter's E-mail.  (Most do.)  

5.  Place the cursor over the mailto link and observe the construct of the link.  If you do not have a Status bar to display the link, right-click on the link and select Copy Link Location (NOT Copy Email Address) and paste the result in a text editor window.  

6.  Select that E-mail link.  

The mailto link appears properly constructed.   The Thunderbird Write window shows my E-mail address for both From: and Reply-To:; however, it does not show an E-mail address for To:.  I tested this with both SeaMonkey 2.21 and Internet Explorer 10.0.9200.16720 and got the same result.

Comment 3

4 years ago
I followed the above steps on Windows 7 with Thunderbird 24.0.1 in safe mode (with a Reply-To address set on my default identity) coming from both Firefox 24.0 and Internet Explorer 10.0.9200.16721 and everything works fine for me.

I can only assume that there's something broken in your TB profile (or maybe the Windows registry), since those are the only differences I can think of that would cause this.

Comment 4

4 years ago
Probably a DUP of Bug 913493, but I'm not 100% sure so leaving open
Whiteboard: DUPME Bug 913493 ?
(Reporter)

Comment 5

4 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.1.0

Re comment #3:  
I do not see any user-oriented way to create a new profile to test the conjecture that this might be a problem with my current profile.  Since my PC is new with a new installation of Windows 7 (x64), I doubt there is a problem with my Windows 7 registry.  

Re comment #4:  
I am not familiar with MAPI and thus cannot assess whether this is the same as bug #913493.  Because this bug describes the problem in terms oriented towards end-users, however, I suggest this bug remain open and not closed as a duplicate of bug #913493.  Otherwise, other end-users might create additional bugs about this same problem.
(Reporter)

Comment 6

4 years ago
Yes, I tried a clean, new profile.  The problem does not exist there.  

Now my problem is that I do not know how to isolate what in my existing profile causes this problem.  I started to create a new profile that would include all my old E-mail, newsgroup, and RSS messages.  That proved too daunting.  I will go to the mozilla.support.thunderbird newsgroup to see if someone can help me.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

4 years ago
Created attachment 8380249 [details]
user.js

Oops!  

I spent over six hours creating a new, clean profile in which I used [Tools > Options] to setup the new profile similarly to the old one.  I then created my two E-mail accounts, three news server accounts, and list of RSS feeds.  I also copied into the new profile the user.js file that I have been using; it is attached to this bug report.  

Now the same problem occurs in the new profile, even in Safe Mode (although I did not install any extensions in the new profile).  Note that the problem occurs when selecting a mailto: link on a Web page in a browser, whether I use IE 10 or SeaMonkey 2.24.  This is NOT about selecting a mailto: link on an HTML-formatted E-mail message in Thunderbird.
(Reporter)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 8

4 years ago
Get rid of this line:

  user_pref("network.protocol-handler.external.mailto", true);
(Reporter)

Comment 9

4 years ago
Re comment #8:  

Wheee!!  It works.  That line was carried over from the user.js in one of my SeaMonkey profiles.  It definitely should not have been.  It tells SeaMonkey not to use its own mail-news component.  I do that so that I do not lose my current mail-news session if I change SeaMonkey profiles (something I might do several times in an hour).  

Again:  RESOLVED
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.