Closed Bug 929875 Opened 6 years ago Closed 5 years ago

[Flatfish][Gallery] Slideshow

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 906542
1.3 Sprint 5 - 11/22

People

(Reporter: gasolin, Unassigned)

References

Details

(Whiteboard: [flatfish][TCP])

Attachments

(1 file)

According to Bug 928254 Gallery Spec, there's a new Slideshow feature in tablet

To play slide show, tap slideshow icon to play in full screen.
* Slideshow only available on photos

Preset transition effect and interval time: Fade in/out,
2.5 sec to show image and 1 sec to transfer image.
* Slideshow settings is under TBD, and the transition will
fine-tune during the implementation.
Blocks: flatfish
Depends on: 929883
Gary suggest we could put slideshow code in share/ folder, thus both gallery slideshow and photoframe can reuse the same code.
After discussion, we'd handle core gallery slideshow function in this bug, left homescreen to gallery slideshow web activity & settings to bug 929883
Depends on: 928254
WIP 
https://github.com/cctuan/gaia/commit/804208da22c6f4c11403356a528c42b2ec61a1ff

I have done a digital_frame.html/css/js , user can define what kinda slide effect in css file and set the class name in the js file,
and then use web activity to launch it .

The pbs I have not yet solved,
1. digitalframe activity cannot be launched: 
I write test code with uitest and try to launch it but it doesn't work. Only after I replace all the content of open.html and use "open" to launch it
2. not yet handle when it stop and return
3. not yet handle when user touch screen
4. not yet handle db events (need UX input)
Hi Neo,

Just some questions.
What should we do if we receive below events in slideshow?
1. db is upgrading or scanning
2. db is unavailable
3. card is removed
4. new picture inserted
Flags: needinfo?(nhsieh)
Assignee: nobody → gduan
As offline discussed, it might be not possible to launch slideshow immediately while we're viewing photos. So, I will try to move it to frames.js and try to less impact our current logic.
hi Neo,

can you please reply comment #4?
blocking-b2g: --- → 1.3+
Target Milestone: --- → 1.3 Sprint 5 - 11/22
as offline discussed, I'll put activity handler inside gallery.js and reuse all the handling method.
Flags: needinfo?(nhsieh)
Attached file Slide_show_131030.pdf
Slideshow & PhotoFrame spec from Neo
WIP
https://github.com/mozilla-b2g/gaia/pull/13543

Still working on
1. performance on tablet: everything works fine on mobile and desktop, but on tablet, the screen seems to repaint each time when image is changed and background image is resized to fullscreen.
2. first slide not equals to currentFileIndex
3. test cases
implementation resource and ETA date are both agree with RD team. this has to be done before 1.3FC
Whiteboard: [Flatfish only][developer+]
blocking-b2g: 1.3+ → ---
Deassign myself from this bug.
Assignee: gduan → nobody
Whiteboard: [Flatfish only][developer+] → [Flatfish only][developer+][TCP]
Whiteboard: [Flatfish only][developer+][TCP] → [flatfish][TCP]
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906542
You need to log in before you can comment on or make changes to this bug.