[Buri]Something wrong with time localization in notification bar when choose Czech (cs) language

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: sync-1, Assigned: JasnaPaka)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created an attachment (id=544397)
 displays {{m}} but not the number of minutes
 
 DEFECT DESCRIPTION:
 time string in the notification bar is wrong when choose CZ language.	
 
  REPRODUCING PROCEDURES:
 1. Receive an SMS message.
 2. Wait at least one minute.
 3. Open the notifications.
 4. You can see a variable ({{m}}) instead of time value.
 5. When you keep the notification and return to it after one hour elapses, the {{m}} variable changes to {{h}}.
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 100%
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Created attachment 820877 [details]
displays {{m}} but not the number of minutes

Clone from brother

Comment 2

5 years ago
Dear Joe, this is shipment blocker now, customer can't accept wrong information in user guide.
blocking-b2g: --- → leo?
Flags: needinfo?(jcheng)
can l10n team take a look? it seems to happen to Czech only. Thanks
Flags: needinfo?(jcheng) → needinfo?(l10n)
Again, not sure which version is this bug related to (I'd say 1.1 based on leo?)

Variables are completely different between Czech (cs) and English. Pavel, can you take a look?

1.1
en-US: http://hg.mozilla.org/releases/gaia-l10n/v1_1/en-US/file/ad14a618e815/shared/date/date.properties#l62
cs: http://hg.mozilla.org/releases/gaia-l10n/v1_1/cs/file/9480259ce0e9/shared/date/date.properties#l62

1.2
en-US: http://hg.mozilla.org/releases/gaia-l10n/v1_2/en-US/file/e8a8a0387061/shared/date/date.properties#l62
cs: http://hg.mozilla.org/releases/gaia-l10n/v1_2/cs/file/e0b355627194/shared/date/date.properties
Flags: needinfo?(l10n) → needinfo?(pcvrcek)
Assignee: nobody → p.franc
Component: Gaia::System → cs / Czech
Product: Boot2Gecko → Mozilla Localizations
Summary: [Buri]Something wrong with time localization in notification bar when choose CZ language → [Buri]Something wrong with time localization in notification bar when choose Czech (cs) language

Comment 5

5 years ago
Hi,
This is the version id:
Firefox os  v1.1
Mozilla build ID:20130916041201
(Assignee)

Comment 6

5 years ago
I'm going to have a look at it.
Assignee: p.franc → pcvrcek
Status: NEW → ASSIGNED
Flags: needinfo?(pcvrcek)
(Assignee)

Comment 7

5 years ago
http://hg.mozilla.org/gaia-l10n/cs/rev/ec28fbcb243f
http://hg.mozilla.org/releases/gaia-l10n/v1_2/cs/rev/a6df859abb45

Fixed. Thanks for the report!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 930303

Comment 9

5 years ago
Uplifted to http://hg.mozilla.org/releases/gaia-l10n/v1_1/cs/ for gaia-l10n, too.
Mass-modify - removal of no longer relevant blocking flags.

Updated

4 years ago
blocking-b2g: leo? → ---
You need to log in before you can comment on or make changes to this bug.