Font issues with internal pdf viewer

RESOLVED FIXED

Status

()

Firefox
PDF Viewer
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: Uwe, Unassigned)

Tracking

24 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][d-direct-write-6.1][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3917)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 820951 [details]
Pharma+Food_Mediainformationen_2014.pdf

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

1. created PDF file using InDesign PDF export with fonts included
2. opened pdf file in Firefox 24.0 (Windows 7 64bit german) internal pdf viewer

(example file included)


Actual results:

3. text is not displayed with the correct font (page 7 and others)




Expected results:

Note: the pdf files can be opened and viewed correctly in any other viewer (Adobe Reader, PDF X-Change Viewer, Adobe Acrobat)
We checked other combinations but the cause is foggy - the bullet at the beginning of the lines is a reason but not alone...

Comment 1

5 years ago
Can you attach a screenshot of the issue on your side. It seems to be fine on my side: http://i.imgur.com/xXHNHK5.jpg
Component: Untriaged → PDF Viewer
Flags: needinfo?(bahnhof65)
(Reporter)

Comment 2

5 years ago
Hi and thanks for the quick answer.
Forgot to add that this glitch happens on all our pc's here at work...
Please check my website for additional screenshots:
http://tutorials.thealb.de/ff/ (four screenshots with both good and error view plus settings window)
thx

Comment 3

5 years ago
I don't see that on page 8. The only issue is about "Smask" on my side (on the right with the tilted URL), but it's a feature unimplemented in PDF Viewer.

I think your issue is about font selection on your computer.

Can you open the console and copy the errors when the PDF is loaded.
(Reporter)

Comment 4

5 years ago
Here you are:
[15:32:52.340] "PDF 8cc2e46bdbaffe43b31a2f6767c427e9 [1.5 Adobe PDF Library 9.9 / Adobe InDesign CS5 (7.0.4)] (PDF.js: 0.8.291)"
[15:32:52.681] "Warning: TODO: graphic state operator SMask"

And you're right: I just double-checked with a private Win7 notebook and the error doesn't show up. 
But since other pdf viewers show the pages correctly there must be some misinterpretation on the internal viewer's side... on our company pc's the error can be reproduced...
Flags: needinfo?(bahnhof65)

Comment 5

5 years ago
One thing you can test is to create a new profile (see https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles) and to test again on the machine where the issue is visible.
(Reporter)

Comment 6

5 years ago
I created a new profile and opened the pdf file with that ff session: the error occurs just the same. Could it be a codepage thingy?
Unable to replicate with FF27 and DirectWrite 6.2.  Can you 1) paste about:graphics here 2) try with FF27?
Flags: needinfo?(bahnhof65)
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-windows][pdfjs-d-direct-write-6.1]
Mozilla/5.0 (Windows NT 6.0; rv:27.0) Gecko/20100101 Firefox/27.0
Reproduced with latest Aurora (20131106004000) on Win Vista with DirectWrite 7.0, but didn't see it on Win 7 x64 with DirectWrite 6.2.

Graphics
Adapter Description	Intel(R) HD Graphics
Adapter Drivers	igdumd32 igd10umd32 igd10umd32
Adapter RAM	Unknown
Device ID	0x0152
Direct2D Enabled	true
DirectWrite Enabled	true (7.0.6002.23097)
Driver Date	3-26-2012
Driver Version	8.15.10.2712
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 10
Vendor ID	0x8086
WebGL Renderer	Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0

Brendan, should I confirm this issue or mark it as duplicate of bug 901288? Thank you
Flags: needinfo?(bdahl)
Most like a duplicate, but hard to be sure. Let's leave this one open.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(bdahl)

Updated

5 years ago
Flags: needinfo?(bahnhof65)
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-windows][pdfjs-d-direct-write-6.1] → [pdfjs-c-rendering][pdfjs-d-font-conversion][d-direct-write-6.1][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3917
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 947260
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.