[traceback] 'NoneType' object has no attribute 'log_feature'

RESOLVED DUPLICATE of bug 929709

Status

Marketplace
Validation
RESOLVED DUPLICATE of bug 929709
4 years ago
4 years ago

People

(Reporter: eviljeff, Unassigned)

Tracking

Points:
---

Details

(Reporter)

Description

4 years ago
http://sentry.mktmon.services.phx1.mozilla.com/mkt/marketplacefirefoxcom/group/1948/

And from the file viewer (I'm guessing its the same traceback):
Validation failed: Traceback (most recent call last): File "./mkt/developers/views.py", line 619, in json_file_validation v_result = tasks.file_validator(file.id) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/lib/python2.6/site-packages/celery/app/task.py", line 330, in __call__ return self.run(*args, **kwargs) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/nuggets/celeryutils.py", line 35, in wrapped return fun(*args, **kw) File "/data/mkt.prod/www/marketplace.firefox.com/deploy-zamboni-prod-20131022182655-5dd8c8a736/zamboni/apps/amo/decorators.py", line 157, in wrapper return f(*args, **kw) File "/data/mkt.prod/www/marketplace.firefox.com/deploy-zamboni-prod-20131022182655-5dd8c8a736/zamboni/apps/amo/decorators.py", line 149, in wrapper return f(*args, **kw) File "./mkt/developers/tasks.py", line 100, in file_validator result = run_validator(file.file_path, url=file.version.addon.manifest_url) File "./mkt/developers/tasks.py", line 116, in run_validator spidermonkey=settings.SPIDERMONKEY) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/validate.py", line 71, in validate_packaged_app submain.prepare_package(bundle, path, timeout) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/submain.py", line 63, in prepare_package test_package(err, package, path) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/submain.py", line 94, in test_package output = test_inner_package(err, package) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/submain.py", line 119, in test_inner_package test(err, package) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/content.py", line 74, in test_packed_packages processed = _process_file(err, package, name, file_data) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/content.py", line 115, in _process_file testendpoint_js.test_js_file(err, name, file_data) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/scripting.py", line 53, in test_js_file trav.run(tree) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/traverser.py", line 59, in run func() File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/nodedefinitions.py", line 68, in wrap func() File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/nodedefinitions.py", line 62, in wrap traverser.traverse_node(node["body"]) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/traverser.py", line 103, in traverse_node action_result = action(self, node) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/nodedefinitions.py", line 23, in BlockStatement traverser.traverse_node(child) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/traverser.py", line 121, in traverse_node self.traverse_node(b) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/traverser.py", line 119, in traverse_node self.traverse_node(branch) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/traverser.py", line 103, in traverse_node action_result = action(self, node) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/nodedefinitions.py", line 236, in UnaryExpression return JSLiteral(UNARY_OPERATORS[node["operator"]](arg), File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/nodedefinitions.py", line 221, in <lambda> "!": lambda e: not e.get_literal_value(), File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/jstypes.py", line 192, in get_literal_value directory = self._get_contents(traverser) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/jstypes.py", line 131, in _get_contents traverser, self.global_data["value"]) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/utils.py", line 67, in evaluate_lambdas return evaluate_lambdas(traverser, node(traverser)) File "/data/mkt.prod/www/marketplace.firefox.com/current/venv/src/app-validator/appvalidator/testcases/javascript/predefinedentities.py", line 31, in wrap t.log_feature(constant) AttributeError: 'NoneType' object has no attribute 'log_feature'

Updated

4 years ago
Duplicate of this bug: 929947
(Reporter)

Comment 2

4 years ago
is this fixed then?  as per https://bugzilla.mozilla.org/show_bug.cgi?id=929947#c1 ?

Comment 3

4 years ago
Oops, bugzilla search failed me
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 929709
You need to log in before you can comment on or make changes to this bug.