Email from Paul Adenot always gets trapped in Postini

RESOLVED WONTFIX

Status

Infrastructure & Operations
Infrastructure: Mail
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: Away for a while, Assigned: justdave)

Tracking

Details

(Reporter)

Description

4 years ago
Every single email that Paul sends to me via his paul at paul.cx email address gets trapped into Postini.  I have probably missed lots of important emails from him. :(
Can we get such an email with complete headers ?

Did you whitelist paul in postini ?
Assignee: server-ops → infra
Component: Server Operations → Infrastructure: Mail
Flags: needinfo?(ehsan)
Product: mozilla.org → Infrastructure & Operations
QA Contact: shyam → limed
(Reporter)

Comment 2

4 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #1)
> Can we get such an email with complete headers ?

I can forward one to whoever is interested.

> Did you whitelist paul in postini ?

No, I shouldn't have to do that!  :-)
Flags: needinfo?(ehsan)
Go ahead and forward one to me.  Forward it as an attachment, so the headers stay intact, please.
Assignee: infra → justdave
(Reporter)

Comment 4

4 years ago
(In reply to comment #3)
> Go ahead and forward one to me.  Forward it as an attachment, so the headers
> stay intact, please.

Done!
The problem is on Paul's end.  He has an SPF record defined for the paul.cx domain:

paul.cx descriptive text "v=spf1 include:mx.ovh.com ~all"

the rule pulled in by that include: directive is:

mx.ovh.com descriptive text "v=spf1 ptr:mail-out.ovh.net ptr:mail.ovh.net ?all"

mail-out.ovh.net has no IP address.
mail.ovh.net has address 213.186.33.220

So according to his DNS setup, the only host permitted to send email from the paul.cx domain is 213.186.33.220

The email you forwarded was sent from 66.111.4.27.

If he wants his mail to not be blocked, he needs to update his SPF record to include the places he's actually sending email from.
(or actually send his email from the places he's defined as being legal to send from)
(Reporter)

Comment 7

4 years ago
Thanks for the analysis, Dave!  Paul, it's on your plate now.  (FWIW I think any email that you have sent to moco folks might be affected.)
Flags: needinfo?(paul)
Interesting to know, and thanks for the analysis, I'll take the appropriate measures. I've been using this email to send Moco people emails for years, though, maybe Postini recently woke up an decided to block me.
Flags: needinfo?(paul)
Yes, Postini SPF filtering was enabled recently, see bug 807414#c15.

Updated

3 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2088]

Updated

3 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2088] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2096]
deleted bogus whiteboard tag
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2096]

Comment 11

3 years ago
Nothing we can do on our end
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.