Closed Bug 930035 Opened 9 years ago Closed 9 months ago

pdf.js (PDF preview) font rendering is sometimes ugly

Categories

(Firefox :: PDF Viewer, defect, P4)

27 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: vincent-moz, Unassigned)

References

()

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-linux])

Attachments

(3 files)

Attached image font-pdfjs.png
Font rendering done by Mozilla's internal PDF viewer (pdf.js) is sometimes ugly.

Note that the status of "Allow pages to choose their own fonts..." doesn't matter. This is *not* bug 738627 (which is fixed in this version, BTW).

For instance, the problem can be seen on:

  http://www.dgdr.cnrs.fr/achats/agence/fichiers/Bonnes%20pratiques-Marche-Voyages-hebergement.pdf

I've attached a part of a screenshot on page 3, obtained with Iceweasel 24 (Debian/unstable). But the same problem occurs with Nightly 27.0a1 (2013-10-23).

External PDF viewers Evince and xpdf do not have any problem on this PDF file.

My Debian bug report:
  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=727225
Priority: -- → P4
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-linux]
Mozilla/5.0 (X11; Linux x86_64; rv:27.0) Gecko/20100101 Firefox/27.0
I couldn't reproduce the issue on latest Aurora (20131118004001).

Do you have hardware acceleration enabled? Thank you
Flags: needinfo?(vincent-moz)
Here's what about:support gives me for Graphics:

Adapter Description	nouveau -- Gallium 0.4 on NV98
Device ID	Gallium 0.4 on NV98
Driver Version	3.0 Mesa 9.2.2
GPU Accelerated Windows	0/1 Basic
Vendor ID	nouveau
WebGL Renderer	nouveau -- Gallium 0.4 on NV98
windowLayerManagerRemote	false
AzureCanvasBackend	cairo
AzureContentBackend	none
AzureFallbackCanvasBackend	none

(I'm currently using Debian's Iceweasel 24.1.0, where I can reproduce the bug.)
Flags: needinfo?(vincent-moz)
Also reproduced using Firefox 25 on WinXP with HWA disabled (blocked due to driver version).
Looks like the font selection is incorrect, so the (wrong) selected font is stretched badly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86_64 → All
Reproduced with the latest PDF.js add-on (0.8.713).
I have the same problem on FF 25.0.1 viewing the same pdf on two Windows 7 x64 systems. The older system has a Radeon X600 graphics card with the Microsoft-supplied drivers, and has an ugly display. The other uses the internal Intel HD graphics on the i3-2100 CPU and is fine. gfx.direct2d.disabled is false on both FF's.
The same on FF esr 24.2.0 with Win XP et 7. It's ok with Chrome or FF+Acrobat Reader.
I just understand that this new feature is buggy at first but why change the pdf reader by default during installation of FF 24??
The same with Firefox Nightly (firefox-29.0a1.en-US.win32.installer.exe)
(In reply to Thomas Blohorn from comment #6)
> I just understand that this new feature is buggy at first but why change the
> pdf reader by default during installation of FF 24??

Thomas, on latest Firefox versions, this pref is set by default (see Options -> Applications: Portable Document Format (PDF) - Preview in Firefox) and can be changed.

I cannot reproduce it with Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:97.0) Gecko/20100101 Firefox/97.0

Does this bug still exist?

Flags: needinfo?(vincent-moz)

The problem reported in comment 10 and comment 11 is unrelated, please open a separate bug for that!

(In reply to Kenan from comment #9)

Does this bug still exist?

Well, when "Allow pages to choose their own fonts..." is unticked, and only in this case, the bug still exists with Firefox 95.0.1 (latest Debian package). So this is a bit different from this bug report, but this would also mean that bug 738627 reappeared!

Flags: needinfo?(vincent-moz)

So perhaps this bug is solved, and what was bug 738627 is now bug 1634572 (currently still open).

Let's call this fixed.
The bug related to blocking web fonts is bug 1563678.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.