Closed Bug 930056 Opened 9 years ago Closed 9 years ago

[B2G][Lockscreen] Receiving a call while on the lockscreen results in the answer/ignore slider not appearing until the screen is tapped.

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, firefox26 unaffected, firefox27 wontfix, firefox28 fixed, firefox29 fixed, b2g-v1.2 unaffected, b2g-v1.3 fixed)

VERIFIED FIXED
1.3 C1/1.4 S1(20dec)
blocking-b2g 1.3+
Tracking Status
firefox26 --- unaffected
firefox27 --- wontfix
firefox28 --- fixed
firefox29 --- fixed
b2g-v1.2 --- unaffected
b2g-v1.3 --- fixed

People

(Reporter: laliaga, Assigned: mtseng)

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

While the screen is on and lockscreen displayed, if the user receives a call the Answer/Ignore slider UI does not appear. Only when the screen is tapped will call UI display.

Repro Steps:
1. Flash to Buri Central MozRil 1.3 10/23.
2. Complete the FTU and leave the screen on with the lockscreen displayed.
3. Have another device call this device.
4. While the phone is ringing, observe lockscreen.
5. Tap the display.

Actual Results:
The Answer/Ignore UI does not display until the screen is tapped.

Expected Results:
The Answer/Ignore UI to display automatically without user interaction.

Repro Rate: 3/5
See Video: http://youtu.be/DTcb0qNHFNc

Environment:
Gaia   6d23c2f9153d0e1d17679cb9c317e75a0ee9a490
SourceStamp 21d97baadc05
BuildID 20131023040203
Version 27.0a1
We should find out if this reproduces on 1.2 or not as well.
blocking-b2g: --- → 1.3?
QA Contact: nkot
Regression range:

-last working-
BuildID: 20131003040204
Gaia: dc68f530ca7d1b182deef0a3787cfdd8f0778612
Gecko: 0e26e6f12ad9
Version: 27.0a1
Firmware: US_20131015

-first broken-
BuildID: 20131004040203
Gaia: 1ac6749e36424124493a1b4c7534f298789bdffd
Gecko: 8f08240128c8
Version: 27.0a1
Firmware: US_20131015

Doesn't happen on Buri aurora 

BuildID: 20131025004000
Gaia: 606517ceafe0950c2b89822d5f13353743334f2c
Gecko: 5eabd267ef04
Version: 26.0a2
1.3+ due to regression
blocking-b2g: 1.3? → 1.3+
Gweng, do you think it's something you could help? Thanks.
Flags: needinfo?(gweng)
I've tested this on the newest Buri PVT build:

Gaia      1d45d1dc3201059d5c8f2efdeb92c04576d8e161
Gecko     http://hg.mozilla.org/mozilla-central/rev/9f12a9fab080
BuildID   20131209053402
Version   28.0a1

and the LockScreen works fine: when the incoming call appears, the lockscreen changed to the Incoming mode and I can just hang up the phone by dragging the handler to the left. I'll provide a video later.
Flags: needinfo?(gweng)
Attached video Successful
The tests I've ran shows the two different results. I attached them all and NI Steve.
Attached video failed.ogv
Flags: needinfo?(schung)
One thing Steve has mentioned is that there may lack the reflow which should be triggered but apparently it wasn't. If this is true, would this become a Gecko bug?
Unagi use the newest build would perform the same symptom as well. Sometimes it successes and the other times not.
Since we will revert fade-in effect for incoming call screen per UX request(Animation was removed in bug 922238), having the animation might be a quick workaround for this issue:

  #call-screen[data-layout="incoming-locked"] {
    opacity: 0;
  }

  #call-screen[data-layout="incoming-locked"].displayed {
    opacity: 1;
    transition: opacity 1s ease 1s;
  }

The tricky part is adding the delay animation, the screen might still unable to render without this delay. But this trick shouldn't be our top priority solution. Any feedbacks from graphics team would be helpful, thanks.
Flags: needinfo?(schung) → needinfo?(slin)
Hi Steve, it does sound like we have suffered from this issue long time ago. Morris (:mtseng) has recently fixed bug 933711, which the issue is about it takes a very long respond time when users try to wake up the screen by power key. I'm not sure bug 933711 is the fix for this one, but I think it's worth trying.
Flags: needinfo?(slin)
Hi, all,

I also can 100% reproduce this bug.
Please refer to the video.
- https://dc1.beta.safesync.com/LMsJysyJ/Cannot%20unlock%20lockscreen.mp4?a=qZZf0JF62p4
* Note: Please turn on the speaker. You can hear the ringing but the answer&ignore icon cannot be displayed.

* Test Build:
 - Gaia:     c952e2756c03eceb4de6a3eba15651741a62f9e8
 - Gecko:    http://hg.mozilla.org/mozilla-central/rev/df82be9d89a5
 - BuildID   20131210040206
 - Version   29.0a1
(In reply to Shelly Lin [:shelly] from comment #11)
> Hi Steve, it does sound like we have suffered from this issue long time ago.
> Morris (:mtseng) has recently fixed bug 933711, which the issue is about it
> takes a very long respond time when users try to wake up the screen by power
> key. I'm not sure bug 933711 is the fix for this one, but I think it's worth
> trying.

Thanks for the information. Media(graphics) team will assign proper candidate for further investigation first.
Component: Gaia::System::Lockscreen → General
Morris, please check whether it relative to compositor
Flags: needinfo?(mtseng)
Attached patch force_invalidate_frame (obsolete) — Splinter Review
dialer app startup but not shown on the screen because sometimes we don't have any retainned data for remote type displayitem and thus Repaint event is not triggered. Repaint event don't fire cause frame tree and layer tree not update. So I force invalidate frame when displayitem type is remote. After doing this, this issue is resolved.
Assignee: nobody → mtseng
Attachment #8347079 - Flags: review?(matt.woodrow)
Flags: needinfo?(mtseng)
My bad. I attached the incorrect video.
Please find the video via the following link.
- https://dc1.safesync.com/LMsJysyJ/Answer%26ignore%20slider%20not%20appearing.3gp?a=8goyg9KZHdM

Many thanks!
Comment on attachment 8347079 [details] [diff] [review]
force_invalidate_frame

Review of attachment 8347079 [details] [diff] [review]:
-----------------------------------------------------------------

Move this up into the same if() condition as TYPE_PLUGIN.
Attachment #8347079 - Flags: review?(matt.woodrow) → review+
https://hg.mozilla.org/mozilla-central/rev/136ca52b0022
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C1/1.4 S1(20dec)
Verified it. I cannot reproduce this bug on latest V1.3 build.

* The tested build:
 - Gaia      5d31cfb04081605a5c4cddd97022ed3210e9bdd0
 - Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/6c6fd43f57a4
 - BuildID   20131222004001
 - Version   28.0a2
  => Cannot reproduce
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.