primary provisioning uncaught exception: target window is same as present window

RESOLVED WONTFIX

Status

()

Core
Identity
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: ozten, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Based on patch from Bug#929243 and a Fx with dom.identity.enabled enabled.

Steps to reproduce:

1) Go to Persona test page like http://123done.org/
2) Click Sign in
3) Enter foo@mockmyid.com

Actual:
Identity IDP: _provisionIdentity: identity: ozten@mockmyid.com url: https://mockmyid.com/browserid/provision.html
Identity IDP: _createProvisioningSandbox: https://mockmyid.com/browserid/provision.html
Identity sandbox: Creating sandbox for: https://mockmyid.com/browserid/provision.html
Identity sandbox: _makeSandboxContentLoaded: 48 https://mockmyid.com/browserid/provision.html
Identity IDP: _provisionIdentity: Created sandbox and provisioning flow with id: 48
nsDOMIdentity (undefined): init was called from https://mockmyid.com/browserid/provision.html
JavaScript error: , line 0: uncaught exception: target window is same as present window -- not allowed
JavaScript error: https://mockmyid.com/browserid/provision.html, line 16: navigator.id.beginProvisioning is not a function


Expected:
A Sandboxed iframe loads https://mockmyid.com/browserid/provision.html and use is provisioned (since mockmyid.com always says "yes, provision this user").
(Reporter)

Updated

4 years ago
Blocks: 882884
(Reporter)

Comment 1

4 years ago
This error message comes from jschannel, a Persona server side script.
We should not be using the SHIM here...

It appears that navigator.id.beginProvisioning should be defined by the native dom, but isn't.
(Reporter)

Comment 2

4 years ago
The issue is that in identity.manifest (http://hg.mozilla.org/mozilla-central/file/8803e8c0ee3e/dom/identity/Identity.manifest) we've renamed the DOM API to mozId.
(Reporter)

Comment 3

4 years ago
Created attachment 832394 [details] [diff] [review]
Fix	sandbox	API and	Desktop	Persona DOM API

Server side support landed.

This patch gets tip Firefox working again, with navigator.mozId instead of navigator.id.

It also provides "rpInfo" inputs into the /auth authentication flow of the fallback IdP.
Attachment #832394 - Flags: review?(MattN+bmo)
Attachment #832394 - Flags: feedback?(jparsons)
Comment on attachment 832394 [details] [diff] [review]
Fix	sandbox	API and	Desktop	Persona DOM API

Review of attachment 832394 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Austin King [:ozten] from comment #4)
> Try server:
> https://tbpl.mozilla.org/?tree=Try&rev=40a0b3c3000f

In the future, please include mochitest and xpcshell test suites.

(In reply to Austin King [:ozten] from comment #3)
> Server side support landed.

Could you point me to the server-side change? I'd like to understand what was wrong and why all of these changes are necessary. It seems like this may be fixing many things in one patch which makes it hard to review.

::: toolkit/identity/IdentityProvider.jsm
@@ +336,3 @@
>      // extract authentication URL from idpParams
> +    let authPath = aIDPParams.idpParams.authentication +
> +      '?' + rpLoginOptions.join('&');

We only want to do this for a fallback provider, right?

::: toolkit/identity/Sandbox.jsm
@@ +102,3 @@
>      docShell.allowWindowControl = false;
> +    // TODO: disable media (bug 759964)
> +    // docShell.allowMedia = false;

I think you want to revert this change
Attachment #832394 - Flags: review?(MattN+bmo) → feedback+
Comment on attachment 832394 [details] [diff] [review]
Fix	sandbox	API and	Desktop	Persona DOM API

Thank you for doing this, Austin.  I give feedback+, and hope that Persona will someday again have support to move forward.
Attachment #832394 - Flags: feedback?(jed+bmo) → feedback+
I'm WONTFIXing persona-related bugs now that we've committed to decommissioning in the persona.or service.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.