Fix an exact rooting hazard in DispatchEvent

RESOLVED FIXED in mozilla27

Status

()

Core
DOM: Workers
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: terrence, Assigned: terrence)

Tracking

Trunk
mozilla27
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.86 KB, patch
Ben Turner (not reading bugmail, use the needinfo flag!)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

5 years ago
Created attachment 821119 [details] [diff] [review]
hazard_event_dispatch-v0.diff

The exact rooting analysis is not able to tell that the existing Vector<Holder> is not safe. Let's just switch this over to AutoValueVector now.

There is a comment in the source about this approach triggering crashes on Android: is there a bug number for that? Hopefully the problem is gone now: if not we should track it down and fix the underlying issue so we can use the correct rooting primitives here.

https://tbpl.mozilla.org/?tree=Try&rev=87580a1fd5a1
Attachment #821119 - Flags: review?(bent.mozilla)
Comment on attachment 821119 [details] [diff] [review]
hazard_event_dispatch-v0.diff

Review of attachment 821119 [details] [diff] [review]:
-----------------------------------------------------------------

Are you sure this works? I wrote almost the exact same patch in bug 814026...

And I filed bug 835826 on it.
Attachment #821119 - Flags: review?(bent.mozilla) → review+
You should review the patch that removes all of this code instead :-P
(Assignee)

Comment 3

5 years ago
Thanks for the bug references! I'm sad we never figured out what was going on there. Opt only crashes make me think it was a compiler issue and I believe we've upgraded since then, even on B2G. In any case, try appears to be quite green now, so it should be good to go.

(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #2)
> You should review the patch that removes all of this code instead :-P

What is the timeframe on that?
(In reply to Terrence Cole [:terrence] from comment #3)
> (In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #2)
> > You should review the patch that removes all of this code instead :-P
> 
> What is the timeframe on that?

Whenever bent and peterv review bug 928312.  Ideally early next cycle.
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/2dc38d7aba6f

Okay, that's not too long to wait if this push fails horribly. Hopefully this will just work, however.
https://hg.mozilla.org/mozilla-central/rev/2dc38d7aba6f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
(Assignee)

Updated

5 years ago
Duplicate of this bug: 835826
You need to log in before you can comment on or make changes to this bug.