Closed Bug 930108 Opened 6 years ago Closed 6 years ago

[B2G][Settings][Your Privacy]Icons on Your Privacy page overlap their Title text.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, firefox29 fixed, b2g18 unaffected, b2g-v1.2 affected, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g 1.3+
Tracking Status
firefox29 --- fixed
b2g18 --- unaffected
b2g-v1.2 --- affected
b2g-v1.3 --- fixed

People

(Reporter: pbylenga, Assigned: arthurcc)

References

Details

(Keywords: regression, Whiteboard: [good first bug][mentor=arthurcc][mentor=ejchen@mozilla.com][mentor-lang=zh][lang=js] LocRun1.2 burirun1.3-1)

Attachments

(4 files)

Description:
The icons on the Your Privacy page overlap their Title text. This is seen with Firefox OS, Marketplace, and everything.me. The issue is not seen during the FTE, screenshot comparison attached.

Repro Steps:
1) Updated Buri to Build ID: 20131016041201
2) Navigate to Settings > Device information
3) Access "Your Privacy" in About Firefox OS section.
4) Observe icons to the left of the titles.

Actual:
Icons overlap their titles

Expected:
Icons and title text are properly spaced and aligned

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131022004000
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/7453a764f9a9
Gaia: 00d5964eabf95a6a8a632420dfa36fc76dcbc9b7
Platform Version: 26.0a2
RIL Version: 01.02.00.019.082 
Firmware Version: US_20131015

Notes:
Repro frequency: 5/5, 100%
See attached: screenshot comparison
This issue does not reproduce in settings on Leo v1.1.0

Environmental Variables
Device: Leo v1.1.0 COM RIL
Build ID: 20131016041201
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/3cbd02abb840
Gaia: 680f3b86b1e4ff1411ece6ba397b8b0e56b4b31c
Platform Version: 18.1
RIL Version: 01.01.00.019.257 
Firmware Version: D300f10a
Duplicate of this bug: 930330
Whiteboard: LocRun1.2
Duplicate of this bug: 930822
Attached image YourPrivacy.png
Also in flatfish.
still reproducible on latest buri v1.2 and buri v1.3

buri V1.2 build
Gaia:     075e60c878b0eca68fba9e00bc85cb6eac03578a                         
Gecko:                                                                     
http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/14868788d50e         
BuildID   20131202004001                                                   
Version   26.0                                                             
ro.build.version.incremental=eng.archermind.20131114.105818  

buri V1.3 build
Gaia:     df070d4eed244e782dd3a7c2a7586d0741eac09f                         
Gecko:    http://hg.mozilla.org/mozilla-central/rev/9ac7ed427cd2           
BuildID   20131203151100                                                   
Version   28.0a1                                                           
ro.build.version.incremental=eng.zxliu.20131101.143946
Whiteboard: LocRun1.2 → LocRun1.2 burirun1.3-1
Flags: needinfo?(swilkes)
Flags: needinfo?(epang)
Attached image inari.png
something similar seems to be happening in Inari as well.  Not overlapped but the incorrect alignment in the settings.  The alignment in the FTE screen is correct and should be followed for both screens.
Flags: needinfo?(swilkes)
Flags: needinfo?(epang)
blocking-b2g: --- → 1.3?
Keywords: regression
Triage: +'ing, major visual glitch.
blocking-b2g: 1.3? → 1.3+
Whiteboard: LocRun1.2 burirun1.3-1 → [good first bug][mentor=arthurcc][mentor=ejchen@mozilla.com][mentor-lang=zh][lang=js] LocRun1.2 burirun1.3-1
Assignee: nobody → arthur.chen
Evelyn, could you help review the change? Thanks!
Attachment #8360976 - Flags: review?(ehung)
PM triaged this bug and believes that it should be a blocker.
Comment on attachment 8360976 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/15401

CSS change, looks okay to me. Thanks!
Attachment #8360976 - Flags: review?(ehung) → review+
Thanks!

master: 01fa20c3bcc200830f162d0d95a91e54b183c021
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Uplifted 01fa20c3bcc200830f162d0d95a91e54b183c021 to:
v1.3: 04f1f724c8a072c61c7b0703ded7a83e04d4042e
You need to log in before you can comment on or make changes to this bug.