Closed Bug 930222 Opened 8 years ago Closed 8 years ago

Settings doesn't use info.mdn to show the phone number for CDMA

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+)

RESOLVED FIXED
blocking-b2g 1.3+

People

(Reporter: anshulj, Assigned: arthurcc)

Details

(Whiteboard: [good first bug][mentor=arthurcc][mentor-lang=zh][lang=js])

Attachments

(1 file)

For CDMA the settings app should use info.mdn and not info.msisdn that it is currently using at http://mxr.mozilla.org/gaia/source/apps/settings/js/about.js#119 to display the Phone number under Device Information menu.

Basically the settings app needs to do something like http://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/RadioInterfaceLayer.js#1111
blocking-b2g: koi? → 1.3?
blocking-b2g: 1.3? → 1.3+
Is there any update on this issue?
Tim, would someone from your team be the right people to help here ? If not, please pass on as appropriate.
Flags: needinfo?(timdream)
Comment 0 probably meant 

https://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/RadioInterfaceLayer.js#1155

Sounds like a good first bug to me :)
Flags: needinfo?(timdream) → needinfo?(arthur.chen)
Whiteboard: [good first bug][mentor=arthurcc][mentor-lang=zh][lang=js]
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #3)
> Comment 0 probably meant 
> 
> https://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/
> RadioInterfaceLayer.js#1155
Yes, that is what I meant. The line number changed since I reported the issue.
> 
> Sounds like a good first bug to me :)
Assignee: nobody → timdream
(In reply to Anshul from comment #4)
> (In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from
> comment #3)
> > Comment 0 probably meant 
> > 
> > https://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/
> > RadioInterfaceLayer.js#1155
> Yes, that is what I meant. The line number changed since I reported the
> issue.
> > 
> > Sounds like a good first bug to me :)

Thanks Tim ! Given the QC FC date nearing, this will be a great help :)
Assignee: timdream → nobody
It's a good first bug.
Flags: needinfo?(arthur.chen)
Ken, can you help with assignee here ?
Flags: needinfo?(kchang)
Arthur, could you please take this bug? Thanks. We can start this fix after FC date.
Flags: needinfo?(kchang) → needinfo?(arthur.chen)
Assignee: nobody → arthur.chen
Flags: needinfo?(arthur.chen)
Evelyn, could you help review this patch?

After checked with Edgar, either msisdn or mdn has value.
Attachment #8339724 - Flags: review?(ehung)
Comment on attachment 8339724 [details]
Link to https://github.com/mozilla-b2g/gaia/pull/14159

Thanks!
Attachment #8339724 - Flags: review?(ehung) → review+
master: 52c20bef0469194c7f8fbda45bfdc71363ccb8f7
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
I'm sorry, but I had to back this out because it blocked backing out bug 932731.  We needed to backout bug 932731 for a settings launch time regression.

Backout revision on master:  87113717c875816361e8c19daa58c1209aae603b
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Land again as bug 932731 has been landed.

master: 144edf47ae4e6d4c1faae204d15351ea251b01e4
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.