Closed Bug 930296 Opened 9 years ago Closed 9 years ago

Subsequent calls to mozSetMessageHandler will not get properly triggered when the app isn't launched

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+)

RESOLVED WORKSFORME
1.3 Sprint 4 - 11/8
blocking-b2g 1.3+

People

(Reporter: cyang, Assigned: julienw)

References

Details

(Keywords: regression)

When receiving MT SMS, if the SMS app was not previously launched, the SMS is never notified to the user (no notification on top and pull down menu does not show anything either). However, launching the SMS app, a new SMS message is there. Once the SMS app has been launched, any subsequent SMS will be notified.

This seems to only be a 1.3 issue as I can't reproduce on 1.2.

Steps to reproduce:
1) Reboot device
2) Send an SMS to a 1.3 device
3) Verify from logs that the message has been received by the 1.3 device
4) Now launch SMS app and see that there's a new SMS message
blocking-b2g: 1.3? → 1.3+
Hey Carol,

could you please explain what a "MT SMS" is ? ;-)

Thanks!
Flags: needinfo?(cyang)
(In reply to Julien Wajsberg [:julienw] from comment #1)
> Hey Carol,
> 
> could you please explain what a "MT SMS" is ? ;-)

Mobile terminated SMS :) Referring to when a device is receiving an SMS (as opposed to a Mobile Originated SMS where the device is issuing the SMS).

> 
> Thanks!
Flags: needinfo?(cyang)
Oki, so this is a normal usual SMS. Thanks!

This looks wrong ;)
Might be related to bug 930604, in that case it would be a gecko problem with not launching an app when we have a system message.
Assignee: nobody → felash
Target Milestone: --- → 1.3 Sprint 4 - 11/8
QA Contact: sparsons
This issue started to occur on the Buri Master Build ID: 20131017040202

Gaia   616e87af0133496620aea89f21ca5d37acedf466
SourceStamp 423b9c30c73d
BuildID 20131017040202
Version 27.0a1

Last working Buri Master Build ID: 20131016040202

Gaia   3d4f1107e6e91e5f5649edc0f2565ac837111d7d
SourceStamp 9f63bbc00527
BuildID 20131016040202
Version 27.0a1
Same regression window than in bug 930604
Summary: MT SMS not notified → SMS received are not notified
Depends on: 932723
We investigated this with Julien and apparently only the first call to mozSetMessageHandler works properly (subsequent handlers will get triggered only if the app is already launched).

This is why:
- the new incoming call works on the dialer even when the app isn't launched
- but not the dial activity

- the new sms reception doesn't works when the sms app isn't open
- but the sms activity does

The dialer calls mozSetMessageHandler for the "telephony-new-call" first, then for the activity, the sms calls mozSetMessageHandler for the activity first, then for the new sms.

Hope this helps, moving to General since this looks system messages related.
Component: Gaia::SMS → General
Summary: SMS received are not notified → Subsequent calls to mozSetMessageHandler will not get properly triggered when the app isn't launched
Fabrice, are you the good person to continue from here?
Flags: needinfo?(fabrice)
That may be a regression from bug 927363. If you can test with this one backed out, great. If not I'll do it but not before next Monday.
We're not supposed to work this Friday so I think next Monday is perfect :)

But that's right that this added line "this.removeMessageListeners(aMessage.name);" could be a good culprit ;)
Blocks: 933133
Just tested that. Indeed, it's a regression of bug 927363. I'm backing out that patch. Please stay tuned.
Close this one as WORKSFORME since bug 927363 which causes regression has been backed out.
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(fabrice)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.