[B2G][Helix][Settings][wangchao]When select "back" in the third level menu of stk, it jump to setting and then auto jump to second level menu of stk.

RESOLVED DUPLICATE of bug 920983

Status

Firefox OS
Gaia::Settings
P2
normal
RESOLVED DUPLICATE of bug 920983
4 years ago
4 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

5.31 MB, video/3gpp
Details
(Reporter)

Description

4 years ago
Created attachment 821417 [details]
VID_0003.3gp

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

【Repro Steps*】:
Please see the attachment.
1.open setting and drag to bottom
2.click "USIM 卡应用", go to the first level menu  
3.click "短信助理", go to the second level menu
4.click "短信保管", go to the third level menu
5.click "back" icon on the top left.

【Expect Result*】:
For 5 step: stk should go back from the 3rd level to 2nd level Menu directly.

【Real Result*】:
For 5 step: stk go back to setting menu and then auto go to 2nd level Menu.

【Test Count*】:5

【Found Count*】:5

【Gaia commit ID*】:20131018 Build V1.1HD

【Gecko commit ID*】: 20131018 Build V1.1HD

【Log*】:reproduce step and real result
(Reporter)

Comment 1

4 years ago
Hi Elelyn:

   This is a issue of Settings, can you share some effort on this?
  
   The attachment video show the step and actual result. Please see it with "【Repro Steps*】".

Thanks!
Flags: needinfo?(ehung)
Priority: -- → P2

Comment 2

4 years ago
(In reply to lecky from comment #1)
> Hi Elelyn:
> 
>    This is a issue of Settings, can you share some effort on this?
>   
>    The attachment video show the step and actual result. Please see it with
> "【Repro Steps*】".
> 
> Thanks!

Yes, the code there is kind of naive without tuning, we will spend some time on optimizing it, but probably won't be on v1.1 but on master.

Arthur, can you mentor someone on this task?
Ian/Tsu-Lin, free to take it if you have some bandwidth.
Flags: needinfo?(ehung)
(Reporter)

Comment 3

4 years ago
Hi Beatriz:

   Evelyn says "probably won't be on v1.1 but on master".

   Will you accept this issue?

Thanks!
Flags: needinfo?(brg)
There was three bugs describing the same functionality, marking this one as duplicated of the oldest one (bug 920983). Lets follow any possible change in this implementation in that bug for the future releases(out of v1.1 scope)

Lecky: there is a timer set to 1 second by default but you can modify it if it improves the user experience of the STK menu. You can find more information about this timer here: 
https://bugzilla.mozilla.org/show_bug.cgi?id=832107

Our experience is that this behaviour will depend on the speed of the SIM car. We set 1 sec as it fits fine in all the testing SIM cards we use in our test environment. Feel free to modify it if you think the experience will be improved. Thanks Fernando for your explanation!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(brg)
Resolution: --- → DUPLICATE
Duplicate of bug: 920983
You need to log in before you can comment on or make changes to this bug.