--enable-ipdl-tests builds broken

RESOLVED FIXED in mozilla27

Status

()

Core
Build Config
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

(Blocks: 1 bug)

Trunk
mozilla27
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
0:05.03 mozbuild.frontend.reader.SandboxValidationError: Reference to a file that doesn't exist in CPP_SOURCES ($(IPDLTESTSRCS)) in ipc/ipdl/test/cxx
(Assignee)

Updated

4 years ago
Blocks: 930377
(Assignee)

Comment 1

4 years ago
Created attachment 822014 [details] [diff] [review]
Fix --enable-ipdl-tests build

This makes things build. The tests fail at runtime, but that's for another bug, which is filed as bug 930377.
Attachment #822014 - Flags: review?(gps)
(Assignee)

Updated

4 years ago
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
Created attachment 822036 [details] [diff] [review]
Fix --enable-ipdl-tests build

Rebased.
Attachment #822036 - Flags: review?(gps)
(Assignee)

Updated

4 years ago
Attachment #822014 - Attachment is obsolete: true
Attachment #822014 - Flags: review?(gps)

Updated

4 years ago
Attachment #822036 - Flags: review?(gps) → review+
(Assignee)

Comment 3

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/748863923653
https://hg.mozilla.org/mozilla-central/rev/748863923653
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla27
Duplicate of this bug: 924964
You need to log in before you can comment on or make changes to this bug.