Closed Bug 930369 Opened 7 years ago Closed 7 years ago

Large favicons are not scaled in the history subview

Categories

(Firefox :: Toolbars and Customization, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: MattN, Assigned: Gijs)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [Australis:P2][Australis:M9])

Attachments

(2 files)

See the screenshot. I don't know if this affects all subsections of the subview or not. We should be using -moz-resolution (like we do on the tab favicons) along with setting a height and width.

Marking as P2 since it's our own start page that causes the issue and it's likely to be in that history menu for many users.
where do we get that icon from? all stored favicons are 16x16 in the backend, so must come from somewhere else
(In reply to Marco Bonardo [:mak] from comment #1)
> where do we get that icon from? all stored favicons are 16x16 in the
> backend, so must come from somewhere else

It's not stored, it's the 'recently closed tabs/windows' menus.
Blocks: 928843
This should do the trick.
Attachment #823271 - Flags: review?(mconley)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 823271 [details] [diff] [review]
fix recently closed favicons,

Review of attachment 823271 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good - thanks Gijs.
Attachment #823271 - Flags: review?(mconley) → review+
https://hg.mozilla.org/projects/ux/rev/75fb5d8c7087
Whiteboard: [Australis:P2] → [Australis:P2][Australis:M9][fixed-in-ux]
Duplicate of this bug: 932941
No longer blocks: 928843
Depends on: 928843
https://hg.mozilla.org/mozilla-central/rev/75fb5d8c7087
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P2][Australis:M9][fixed-in-ux] → [Australis:P2][Australis:M9]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.