B2G RIL: (Unagi) The network keep in "Emergency Calls only" after Turning ON/OFF the airplane mode during sending/receiving MMS

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: bevis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 821487 [details]
device log repoduced from unagi

Reproducible steps on 'unagi':
1. Compose a MMS and send.
2. Turn ON airplane mode while data connection of MMS is established and MMS transaction is sending.
3. Turn OFF airplane mode.
4. Enter SIM per device request.
5. Device is kept in "Emergency Call Only", signal strength is also invalid.

How to recover:
Reboot the device.

Log analysis:
[Device setup 'internet' data call after boot up]
10-24 13:01:44.628   110   110 I Gecko   : -*- RadioInterface[0]: 'ril.radio.disabled' is now false
10-24 13:01:48.271   110   110 I Gecko   : -*- RadioInterface[0]: Reported radio state is off, desired radio enabled state is true
10-24 13:01:48.271   110   110 I Gecko   : -*- RadioInterface[0]: Setting radio power to true
10-24 13:10:05.546   110   110 I Gecko   : -*- RadioInterface[0]: Data call settings: connect data call.
10-24 13:10:05.546   110   110 I Gecko   : -*- RILNetworkInterface[0:1]: Going to set up data connection with APN internet
10-24 13:10:08.731   110   110 I Gecko   : -*- RadioInterface[0]: Data call settings: connect data call.
10-24 13:10:14.447   110   239 I Gecko   : RIL Worker[0]: Handling parcel as REQUEST_SETUP_DATA_CALL
10-24 13:10:14.457   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"status":0,"suggestedRetryTime":-1,"cid":"0","active":2,"type":"IP","ifname":"rmnet0","ipaddr":"100.84.123.181/30","dns":["168.95.1.1","168.95.192.1"],"gw":"100.84.123.182","ip":"100.84.123.181","netmask":"255.255.255.252","broadcast":"100.84.123.183","state":1,"radioTech":3,"apn":"internet","chappap":3,"pdptype":"IP","rilMessageType":"datacallstatechange"}
10-24 13:10:14.457   354   354 I Gecko   : -*- RILContentHelper: Received message 'RIL:DataInfoChanged': {"clientId":0,"data":{"connected":true,"emergencyCallsOnly":false,"roaming":false,"network":{"longName":"Chungwa","shortName":"Chungwa","mcc":"466","mnc":"92"},"cell":{"gsmLocationAreaCode":10235,"gsmCellId":19266557},"type":"umts","signalStrength":-67,"relSignalStrength":100,"state":"registered"}}
10-24 13:10:14.457   110   110 I Gecko   : -*- RILNetworkInterface[0:1]: Data call ID: 0, interface name: rmnet0, APN name: internet

[Setup MMS data connection and start sending MMS]
10-24 13:10:36.678   110   110 I Gecko   : -@- MmsService: createSavableFromParams: aMessage: {"headers":{"to":[{"address":"0978502192","type":"PLMN"}]},"parts":[{"headers":{"content-type":{"media":"application/smil","params":{"name":"smil.xml","charset":{"charset":"utf-8"}}},"content-location":"smil.xml","content-id":"<smil>"},"content":"<smil><head><layout><root-layout width=\"320px\" height=\"480px\"/><region id=\"Image\" left=\"0px\" top=\"0px\" width=\"320px\" height=\"320px\" fit=\"meet\"/><region id=\"Text\" left=\"0px\" top=\"320px\" width=\"320px\" height=\"160px\" fit=\"meet\"/></layout></head><body><par dur=\"5000ms\"><img src=\"untitled.jpg\" region=\"Image\"/></par></body></smil>"},{"headers":{"content-type":{"media":"image/jpeg","params":{"name":"untitled.jpg"}},"content-location":"untitled.jpg","content-id":"<untitled.jpg>"},"content":{}}],"type":"mms","timestamp":1382591436684,"receivers":["0978502192"],"sender":null,"deliveryStatusRequested":false}
10-24 13:10:36.798   110   110 I Gecko   : -@- MmsService: Saving sending message is done. Start to send.
10-24 13:10:37.429   110   110 I Gecko   : -*- RILNetworkInterface[0:2]: Going to set up data connection with APN emome
10-24 13:10:39.271   110   239 I Gecko   : RIL Worker[0]: Handling parcel as REQUEST_SETUP_DATA_CALL
10-24 13:10:39.291   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"status":0,"suggestedRetryTime":-1,"cid":"1","active":2,"type":"IP","ifname":"rmnet1","ipaddr":"10.31.152.185/30","dns":["10.1.7.1","10.1.7.2"],"gw":"10.31.152.186","ip":"10.31.152.185","netmask":"255.255.255.252","broadcast":"10.31.152.187","state":1,"radioTech":3,"apn":"emome","user":"","passwd":"","chappap":3,"pdptype":"IP","rilMessageType":"datacallstatechange"}
10-24 13:10:39.291   110   110 I Gecko   : -*- RILNetworkInterface[0:2]: Data call ID: 1, interface name: rmnet1, APN name: emome
10-24 13:10:41.123   110   110 I Gecko   : -@- MmsService: applyFilter: MMSC/Content Location is matched with: {"uri":"{\"spec\":\"http://mms.emome.net:8002/\",\"prePath\":\"http://mms.emome.net:8002\",\"scheme\":\"http\",\"userPass\":\"\",\"username\":\"\",\"password\":\"\",\"hostPort\":\"mms.emome.net:8002\",\"host\":\"mms.emome.net\",\"port\":8002,\"path\":\"/\",\"asciiSpec\":\"http://mms.emome.net:8002/\",\"asciiHost\":\"mms.emome.net\",\"originCharset\":\"UTF-8\",\"ref\":\"\",\"specIgnoringRef\":\"http://mms.emome.net:8002/\",\"hasRef\":false}","proxyInfo":{"host":"10.1.1.1","port":8080,"type":"http","flags":1,"resolveFlags":0,"failoverTimeout":1800,"failoverProxy":null,"TRANSPARENT_PROXY_RESOLVES_HOST":1}}

[User turned ON Airplane mode]
10-24 13:10:41.573   110   110 I Gecko   : -*- RadioInterface[0]: 'ril.radio.disabled' is now true
10-24 13:10:41.573   110   110 I Gecko   : -*- RadioInterface[0]: Reported radio state is ready, desired radio enabled state is false
10-24 13:10:41.573   110   110 I Gecko   : -*- RILNetworkInterface[0:3]: Going to disconnet data connection 0
10-24 13:10:41.583   110   110 I Gecko   : -*- RILNetworkInterface[0:3]: Going to disconnet data connection 1
10-24 13:10:43.975   110   239 I Gecko   : RIL Worker[0]: Handling parcel as REQUEST_DEACTIVATE_DATA_CALL
10-24 13:10:43.975   110   110 I Gecko   : -*- RILNetworkInterface[0:3]: Data call ID: 0, interface name: rmnet0, APN name: internet
10-24 13:10:43.995   110   110 I Gecko   : -*- RadioInterface[0]: Setting radio power to false
10-24 13:10:43.995   110   239 I Gecko   : RIL Worker[0]: Received chrome message {"on":false,"rilMessageToken":15,"rilMessageType":"setRadioPower"}
10-24 13:10:44.276   110   239 I Gecko   : RIL Worker[0]: Handling parcel as REQUEST_DEACTIVATE_DATA_CALL
10-24 13:10:44.276   110   110 I Gecko   : -*- RILNetworkInterface[0:3]: Data call ID: 1, interface name: rmnet1, APN name: emome
10-24 13:10:44.286   110   110 I Gecko   : -*- RadioInterface[0]: All data connections are disconnected, set radio off.
10-24 13:10:44.296   110   110 I Gecko   : -*- RadioInterface[0]: Setting radio power to false
10-24 13:10:44.316   110   239 I Gecko   : RIL Worker[0]: Received chrome message {"on":false,"rilMessageToken":16,"rilMessageType":"setRadioPower"}
10-24 13:10:46.017   110   239 I Gecko   : RIL Worker[0]: Solicited response for request type 23, token 196, error 0
10-24 13:10:46.017   110   239 I Gecko   : RIL Worker[0]: Handling parcel as REQUEST_RADIO_POWER

[User turned OFF Airplane mode and supply SIM PIN]
10-24 13:11:10.581   110   110 I Gecko   : -*- RadioInterface[0]: 'ril.radio.disabled' is now false
10-24 13:11:10.581   110   110 I Gecko   : -*- RadioInterface[0]: Reported radio state is off, desired radio enabled state is true
10-24 13:11:10.581   110   110 I Gecko   : -*- RadioInterface[0]: Setting radio power to true
10-24 13:11:10.581   110   239 I Gecko   : RIL Worker[0]: Received chrome message {"on":true,"rilMessageToken":17,"rilMessageType":"setRadioPower"}
10-24 13:11:11.452   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"networkinfochanged","operator":{"rilMessageType":"operatorchange","longName":null,"shortName":null,"mcc":null,"mnc":null},"signal":{"voice":{"signalStrength":null,"relSignalStrength":null},"data":{"signalStrength":null,"relSignalStrength":null},"rilMessageType":"signalstrengthchange"}}
10-24 13:11:11.572   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"cardstatechange","cardState":"pinRequired"}
10-24 13:11:11.913   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"networkinfochanged","operator":{"rilMessageType":"operatorchange","longName":null,"shortName":null,"mcc":null,"mnc":null},"signal":{"voice":{"signalStrength":null,"relSignalStrength":null},"data":{"signalStrength":null,"relSignalStrength":null},"rilMessageType":"signalstrengthchange"}}
10-24 13:11:11.943   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"lockType":"pin","requestId":"id{a7f29a84-974a-4a11-bfed-b42fa0669c48}","rilMessageToken":19,"rilMessageType":"iccGetCardLockRetryCount","errorMsg":"RequestNotSupported","success":false}
10-24 13:12:16.045   110   110 I Gecko   : -*- RadioInterfaceLayer: Received 'RIL:UnlockCardLock' message from content process
10-24 13:12:16.045   110   239 I Gecko   : RIL Worker[0]: Received chrome message {"lockType":"pin","pin":"0000","requestId":"id{d66c69ee-a2f6-471b-9f4b-6ff0d0aead25}","rilMessageToken":20,"rilMessageType":"iccUnlockCardLock"}
10-24 13:12:16.426   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"cardstatechange","cardState":"unknown"}
10-24 13:12:16.586   110   239 I Gecko   : RIL Worker[0]: All pending network info has been received: {"rilMessageType":"networkinfochanged","operator":{"rilMessageType":"operatorchange","longName":null,"shortName":null,"mcc":null,"mnc":null},"signal":{"voice":{"signalStrength":null,"relSignalStrength":null},"data":{"signalStrength":null,"relSignalStrength":null},"rilMessageType":"signalstrengthchange"}}
10-24 13:12:16.646   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"cardstatechange","cardState":"personalizationReady"}
10-24 13:12:16.646   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"networkinfochanged","operator":{"rilMessageType":"operatorchange","longName":null,"shortName":null,"mcc":null,"mnc":null},"signal":{"voice":{"signalStrength":null,"relSignalStrength":null},"data":{"signalStrength":null,"relSignalStrength":null},"rilMessageType":"signalstrengthchange"}}
10-24 13:12:16.836   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"networkinfochanged","operator":{"rilMessageType":"operatorchange","longName":null,"shortName":null,"mcc":null,"mnc":null},"signal":{"voice":{"signalStrength":null,"relSignalStrength":null},"data":{"signalStrength":null,"relSignalStrength":null},"rilMessageType":"signalstrengthchange"}}
10-24 13:12:17.507   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"cardstatechange","cardState":"ready"}

[Device got invalid networkinfochanged from modem]
10-24 13:12:17.627   110   110 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"rilMessageType":"networkinfochanged","operator":{"rilMessageType":"operatorchange","longName":null,"shortName":null,"mcc":null,"mnc":null},"signal":{"voice":{"signalStrength":null,"relSignalStrength":null},"data":{"signalStrength":null,"relSignalStrength":null},"rilMessageType":"signalstrengthchange"}}
(Reporter)

Comment 1

5 years ago
After testing the same scenario in Nexus 4 with ROM version on Dashboard (http://release1-qa.corp.tpe1.mozilla.com:8080/job/B2G.master.nexus4/90/), I can not reproduce this problem in Nexus 4 device.
It's more likely to be device-specific issue.

Bevis Tseng
I saw this on my Unagi before updates got turned off in some kind of alternation with 'No network' (bug 920581).

Saw the issue ('Emergency calls only') today on a Keon, restarting didn't fix the issue, calling a number told me that I would be in airplane mode (neither notification bar nor settings showed an active airplane mode). After moving the SIM card to a different device and calling another SIM in the Keon (which worked) and moving it back into the Keon, the issue is gone.

Keon with Boot2Gecko 1.2.0.0-prerelease 20130228225522, update channel 'default'
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.