Bug 930569 (Emoticons)

[Keyboard] Add Emoticons

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
7 months ago

People

(Reporter: padamczyk, Assigned: luigitedone)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, bokken, URL)

(Reporter)

Description

5 years ago
It would be great to add emoticons to SMS/MMS messages to enhance the user experience.

This would function on a visual / display level. I foresee it working like this:

+ When a user types a combination of keys ie. :) it would become a smiley face. 
+ This key combination mode would be an option that could be turned OFF, but perhaps would be ON by default
+ There should also be an option / icon in the UI for inserting emoticons which would pop up a screen with all the emoticons listed.


There would be around 20 key combinations to be replaced by bitmap emoticons:

Happy :)
Sad :(
Winking ;)
Tongue sticking out :P
Surprised =O
Kissing :*
Yelling :O
Cool B)
Money mouth :$
Foot in mouth :!
Embarrassed :S
Angel O:)
Undecided :\
Crying :’(
Lips sealed :X
Laughing :D
Confused o_O
Heart <3
Angry x(
Smirk :/
Poker face :|
Frown :[
There is no specification for this, but it seems like a nice feature, so maybe let's start a discussion.

@ayman, what do you think about this?

@victoria, same question

@evelyn, can you give a reasonable estimation of engineering effort?
Assignee: nobody → evelyn
Flags: needinfo?(vpg)
Flags: needinfo?(evelyn)
Flags: needinfo?(aymanmaat)
Summary: [SMS/MMS] Add Emoticons → [Messages] Add Emoticons

Comment 2

5 years ago
(In reply to Rick Waldron [:rwaldron] from comment #1)
> There is no specification for this, but it seems like a nice feature, so
> maybe let's start a discussion.
> 
> @ayman, what do you think about this?
> 
> @victoria, same question
> 
> @evelyn, can you give a reasonable estimation of engineering effort?

I think its a great idea from Patryk, a logical progression of the apps functionality and bang in line with user expectations. 

In terms of channelling Dev and Design resource it just needs to be decided in what version to include/execute this feature, and whether or not its introduction is a prompt for enhancing the building blocks to facilitate an alteration the message app interface (which is something that needs to be done soon, because it is less than optimal)... that, of course is all a decision for product.
Flags: needinfo?(aymanmaat)
(In reply to ayman maat :maat from comment #2)
> (In reply to Rick Waldron [:rwaldron] from comment #1)
> > There is no specification for this, but it seems like a nice feature, so
> > maybe let's start a discussion.
> > 
> > @ayman, what do you think about this?
> > 
> > @victoria, same question
> > 
> > @evelyn, can you give a reasonable estimation of engineering effort?
> 
> I think its a great idea from Patryk, a logical progression of the apps
> functionality and bang in line with user expectations. 
> 
> In terms of channelling Dev and Design resource it just needs to be decided
> in what version to include/execute this feature, and whether or not its
> introduction is a prompt for enhancing the building blocks to facilitate an
> alteration the message app interface (which is something that needs to be
> done soon, because it is less than optimal)... that, of course is all a
> decision for product.

Excellent! 

Also, thanks for the super quick response :)
(In reply to Rick Waldron [:rwaldron] from comment #1)
> 
> @evelyn, can you give a reasonable estimation of engineering effort?

I think that would heavily depend on whether this is a system feature that any app can tap into, in which case perhaps this would be a Keyboard (system app) feature and not a Messages app feature.  For example, typing emoticons into a Notepad app, or a form in a browser, etc, etc.

If it's a Keyboard/system change, it would probably be a bigger engineering effort that would take a while to understand, plan and estimate.
If it's a Messages-only change, it would be much more contained, and the engineering effort would be easier to estimate.
Flags: needinfo?(evelyn)
Patryk commented this idea offline, I also think it is a nice thing to have, expected. I wouldn't mind designing the emoticons also. 



(In reply to Rick Waldron [:rwaldron] from comment #1)
> There is no specification for this, but it seems like a nice feature, so
> maybe let's start a discussion.
> 
> @ayman, what do you think about this?
> 
> @victoria, same question
> 
> @evelyn, can you give a reasonable estimation of engineering effort?
Flags: needinfo?(vpg)

Updated

5 years ago
Whiteboard: visual design, visual-tracking, bokken
(Reporter)

Updated

5 years ago
Summary: [Messages] Add Emoticons → [MMS/SMS] Add Emoticons
Please don't retitle to the old annotation, we're explicitly moving towards the single name for the app. 

This should be a custom keyboard that produces custom emoji/emoticons inline.
Summary: [MMS/SMS] Add Emoticons → [Messages] Add Emoticons
(Reporter)

Updated

5 years ago
Blocks: 950175
No longer blocks: 930561
Assignee: evelyn → nobody
(Reporter)

Updated

5 years ago
Duplicate of this bug: 950177
I still don't see how this can be implemented for "Messaging App" without speaking about other apps.
If it's going to be some kind of a panel, won't it be confusing when using keyboard and "Emoticons panel" in the same time while texting ?
My suggestion is that it gets implemented inside the Keyboard app itself, thus:
1) It will be then used widely in any other app, so the bug title could be changed a little then.
2) We might then have to find a way to implement a slightly different keyboard layout that lists all the emoticons in a better way than when listing characters we tap on to form a text.
So to recap, IMO, it would perfectly make sense to implement it as part of the Keyboard app and not limit it to Messaging App
:)

Comment 9

5 years ago
We agreed in an email thread, and per comment #8, to move emoticon work to Keyboard. I have changed the component on this bug to reflect this, added Bruce, and will change the bugs to show that this bug lives in System and not in Messaging in terms of visual refresh work for 2.0
Component: Gaia::SMS → Gaia::Keyboard
Target Milestone: --- → 1.5 S1 (9may)

Updated

5 years ago
Alias: Emoticons
Summary: [Messages] Add Emoticons → [Keyboard] Add Emoticons

Updated

5 years ago
No longer blocks: 950175

Updated

5 years ago
Blocks: 950756
(Reporter)

Updated

5 years ago
No longer blocks: 950756
Whiteboard: visual design, visual-tracking, bokken → ux-tracking, visual design, visual-tracking, bokken
I don't agree on auto-converting text in SMS messages into icons though. Skype does this and it drives me f*n nuts. Try pasting code into Skype, it makes all my function(e) into little envelopes. Having an emoji keyboard makes sense, as that would no longer require Loqui and ConnectA2 to ship their own.
Maybe we could be smart about it and like, convert only composed smileys that stand between spaces, or we can do better by having it like a feature that can be turned on and off.. More complexity but also more happy people I guess. :)

Comment 12

5 years ago
I am with Jan. Please, no auto-converting. Maddening. :)
(Assignee)

Comment 13

5 years ago
I think it would be good to have another keyboard layout with all the emoticons and this can be easily implemented. The auto-converting would be a plus that maybe can be enabled or disabled with an option into settings.
(Assignee)

Updated

5 years ago
Assignee: nobody → luigitedone

Comment 14

5 years ago
I don't see why there should be auto-conversion of ascii-smileys.

The only option I see is implementing emojis, since they are "simple" unicode characters and would automatically be compatible with other devices (i.e., your friends see them pretty much like you do). http://en.wikipedia.org/wiki/Emoji

Updated

4 years ago
Target Milestone: 2.0 S1 (9may) → ---
If auto-conversion is not needed, then this work to support emoji could be tracked by bug 993899.

Omega, could you please help confirm that auto-conversion is not necessary?
Flags: needinfo?(ofeng)
Right, auto-conversion is not necessary.
What I'm thinking is when user is typing ":)", there is a smiley face showing on the suggestion bar. That should be system-wised, not only for Messages app.
Flags: needinfo?(ofeng)

Comment 17

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.