emails don't sort stick together

VERIFIED WORKSFORME

Status

MailNews Core
Database
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: ob_email, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

On downloading email sometimes (appearently now more often) emails that arrive
appear as new and are sortet correctly by sender it has just no "send date", but
if you select them the text of another older email shows up
Appearently this is caused by a single carriage return w/o a line feed
separating the new email from the one before.
After rebooting or one day later or so the email might show correctly, but is
not sorted correctly

Reproducible: Didn't try
Steps to Reproduce:
I assume if you remove the line feed before the From in the header of the new
mail and any cr/lf s preceeding it you might see the symptoms the reverse action
(putting cr/lf for the single cr fixes it)

Actual Results:  The mail will probably not be separatet correctly from the one
before, but still doesn't show up

Expected Results:  Ensure a newly downloaded email is definitely separated from
the one before

I don't know if this bug has been reported before, because I couldn't contact
mozilla the last two days. So I don't know if it has been reported/or fixed yet
(sorry if that is the case)

I just got really annoyed when I had to read my mail the second day in a row
with a text editor

Updated

17 years ago
QA Contact: esther → laurel

Comment 1

17 years ago
Marking these all WORKSFORME sorry about lack of response but were very
overloaded here. Only reopen the bug if you can reproduce with the following steps:

1) Download the latest nightly (or 0.9.6 which should be out RSN)
2) Create a new profile
3) test the bug again

If it still occurs go ahead and reopen the bug. Again sorry about no response
were quite overloaded here and understaffed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 2

17 years ago
Worksforme in current trunk builds.
Marking verified worksforme
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.