Add Firefox & You signup form to /new page

VERIFIED FIXED

Status

www.mozilla.org
Newsletters
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Jessilyn Davis, Assigned: agibson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1180176] , URL)

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 821975 [details]
Mockup_new_Signup.jpg

For users who visit https://www.mozilla.org/firefox/new/ and get a "Congrats!" message, can we show the Firefox & You newsletter subscription box? 

The box will be like the "Get Firefox news" sign up box on https://www.mozilla.org/en-US/firefox/central/

Something like the attached mockup.

Can that happen?

Comment 1

5 years ago
+1 so long as this is only shown to Firefox users on the most recent version.

Comment 2

5 years ago
(In reply to Laura Forrest from comment #1)
> +1 so long as this is only shown to Firefox users on the most recent version.

+1 agree. Since we have conditional blocks on the download page now, we can put this newsletter content in the area for people running the latest version.

Updated

5 years ago
Whiteboard: [kb=1180176]
(Reporter)

Comment 3

5 years ago
Created attachment 830982 [details]
screenshot of after downloading

Quick question: Can we also showed them the signup form after they click the download button and below the steps to install?

http://www.mozilla.org/en-US/firefox/new/#download-fx

See screenshot.

Updated

5 years ago
Flags: needinfo?(lforrest)
Flags: needinfo?(chrismore.bugzilla)

Comment 4

5 years ago
(In reply to Jessilyn Davis from comment #3)
> Created attachment 830982 [details]
> screenshot of after downloading
> 
> Quick question: Can we also showed them the signup form after they click the
> download button and below the steps to install?
> 
> http://www.mozilla.org/en-US/firefox/new/#download-fx
> 
> See screenshot.

I like that idea and putting it on the "second scene" of /firefox/new/ shouldn't hurt anything. I would support that idea.

Here is the logic to display the newsletter form:

1) If you are running the latest version.

2) If the second scene is being displayed (#download-fx in the URL).
Flags: needinfo?(chrismore.bugzilla)
(Reporter)

Comment 5

5 years ago
Excellent! Thanks Chris!

Laura - do you have any objections to showing the Firefox & You signup form in the scenarios above (Comment 4)?
(Reporter)

Comment 6

5 years ago
Just synced up with cmore and Holly. 

Here is the logic to display the newsletter form for Firefox & You on /new:

1) If you are running the latest version.



We will not show it on the 2nd instance of /new. P1 for these new users is to open Firefox, which the steps show. Once they open Firefox they will land on /whatsnew  (or /firstrun) - where there is a newsletter signup form.


Mike - can you assign this to someone who can make this change happen in Q1?
Flags: needinfo?(lforrest)
Additional details:
For users that are up-to-date that land on /new we are not currently providing a way for them to sign up for the newsletter. For up-to-date users we will add the following: 
- display the Firefox newsletter sign-up 
- display social links on this page

/new allows us to present conditional content depending on user type (up-to-date, not up-to-date, OS, etc)

Jess, can you define what social links you would like? Links to Twitter and Facebook or "Like" and "Share" actions?
Flags: needinfo?(jdavis)
(Reporter)

Comment 8

5 years ago
Michaela, can you let Holly know exactly how you'd like the social join links/images to look on this page?
Flags: needinfo?(jdavis) → needinfo?(mthayer)

Comment 9

5 years ago
Hi team -- share functionality is the best, but we have some privacy issues with how we do it. Ultimately, I would love to find a way for users to share that they've downloaded Firefox, in efforts to prompt their friends to do the same on Facebook and Twitter.
Flags: needinfo?(mthayer)

Comment 10

5 years ago
(In reply to mthayer@mozilla.com from comment #9)
> Hi team -- share functionality is the best, but we have some privacy issues
> with how we do it. Ultimately, I would love to find a way for users to share
> that they've downloaded Firefox, in efforts to prompt their friends to do
> the same on Facebook and Twitter.

We currently have "share" functionality on the /new page now. See here: http://cl.ly/image/1o2E2Q2Y3c1i

The Facebook/G+ likes the content and posts it to your wall and Twitter allows you to write a custom message and post it. The share functionality only displays after you have downloaded the product and you can test this for yourself on a non-Firefox browser.
(Assignee)

Updated

5 years ago
Assignee: nobody → agibson
Status: NEW → ASSIGNED
(Assignee)

Comment 11

5 years ago
Created attachment 8367873 [details] [review]
GitHub pull request
(Assignee)

Comment 12

5 years ago
Submitted a PR which adds the newsletter signup form to the first scene for up-do-date users. 

As Chris mentions, we already have existing share functionality on "scene2" for users who have downloaded Firefox.

Thanks
(Assignee)

Comment 13

5 years ago
Created attachment 8367901 [details]
newsletter-grab.png

Screenshot of the newsletter in place on /new page
(Reporter)

Comment 14

5 years ago
Sweet! Thanks Alex! Looks great to me.
(Reporter)

Comment 15

5 years ago
Can someone let us know when this is somewhere to be tested before it goes live?  Thanks!
(Assignee)

Comment 16

5 years ago
(In reply to Jessilyn Davis from comment #15)
> Can someone let us know when this is somewhere to be tested before it goes
> live?  Thanks!

I'll see if I can find a demo server to put this change on. thanks
(Assignee)

Comment 17

5 years ago
This is now up on demo3 for testing: https://www-demo3.allizom.org/en-US/firefox/new/
(Reporter)

Comment 18

5 years ago
Thanks Alex!  Rebecca or Raymond - can one of you test whenever you get a moment? This isn't a P1, but something we want to go live sooner rather than later.
I'll look at this today
Verified able to sign up on multiple locales with different languages, and HTML & text.
>> I got please confirm emails from FR and ES, but a Thanks for subscribing from RU

Is this expected?
(Reporter)

Comment 21

5 years ago
(In reply to Rebecca Billings [:rbillings] from comment #20)

> >> I got please confirm emails from FR and ES

Perfect.


>but a Thanks for subscribing from RU

Was it a brand new/unique email address? Or one that was used for another signup form in the past?

If it was brand new/unique - it should have been a confirm email.

If that email address was already in the system (Master_Subscribers table subscribed to a different newsletter), you would have gotten a thanks for subscribing.
I re-tested today, and I don't know for sure that I was using unique email addresses yesterday. I can confirm that unique email addresses from /RU today send a confirm email, and after confirming a Thanks- so as expected. 

Let me know if there are any other details that need testing- right now it looks good. I did not review social sharing.
(Reporter)

Comment 23

5 years ago
Thanks Rebecca! Only the email part was for this bug. It looks like the social sharing needs to be tackled in a different bug so we can close this one out when it goes to prod. I just opened a separate bug for this:
Bug 968966 - Add social sharing to /new page for up-to-date users


It looks like this is good to move to prod! Keep us posted on when it will go live.

Thanks!

Comment 24

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/7cffecdce5d0673c2e04488aa14a2922066e5948
[fix bug 930752] Add Firefox and you signup form to new page

https://github.com/mozilla/bedrock/commit/9e11ab1684cbc8f2c85399e26671ced33de61279
Merge pull request #1641 from alexgibson/bug-930752-add-signup-form-new-page

[fix bug 930752] Add Firefox and You signup form to /new page

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 25

5 years ago
\o/ Thanks everyone! Just gave it a whirl and it was beautiful :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.