Epic Demo: Audio Regression - No Sound Effects

RESOLVED INVALID

Status

()

Core
Web Audio
RESOLVED INVALID
4 years ago
2 years ago

People

(Reporter: Marc Schifer [mschifer], Unassigned)

Tracking

(Blocks: 1 bug)

27 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [games])

(Reporter)

Description

4 years ago
All sound effects are gone as of build 27.0a1 2013-10-18. 
Only the background music plays, all other audio output is gone, (No weapons sounds, no voice overs, etc..)
(Reporter)

Comment 1

4 years ago
One more thing: Music Audio hicups about every minute and 15 seconds as well starting in the same build.
(Reporter)

Comment 2

4 years ago
Retested on 27.0a1 (2013-10-25) and the sound effects are back, the audio hiccups are still present and repeat on around a minute 15 to a minute and a half intervals for the length of play.

Updated

4 years ago
Blocks: 710398
What is the URL or the "Epic Demo" and is this still an issue ?
Flags: needinfo?(mschifer)
(Reporter)

Comment 4

3 years ago
Kind of - the sound effects seem to just queue up in the background until the end of the game and then play out as one big loop. 

the demo can be found here:
http://nick.corp.mtv2.mozilla.com/epic-sanctuary/UDKGame-Browser-Shipping-Sanctuary.html
Flags: needinfo?(mschifer)
That is a mozilla internal URL and not accessible for me as contributor.
Moving to audio/video as guess
Component: General → Video/Audio
Anthony, who can take a look at this?
Flags: needinfo?(ajones)
We disabled the old Audio Data API in Firefox 28 (by changing the default value of the media.audio_data.enabled pref from true to false) in bug 927245.  If I had to guess, I'd say the demo was using the Audio Data API in 27 and the Web Audio API in 28 onwards.  Does the demo work in Chrome?
Looks like Epic need to fix this.
Flags: needinfo?(ajones)
Is this bug still relevant?
Component: Audio/Video → Web Audio
Flags: needinfo?(mschifer)
(Reporter)

Comment 10

2 years ago
As far as I know, the demo is obsolete so we can close this.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mschifer)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.