Closed Bug 930831 Opened 7 years ago Closed 6 years ago

Run clobberer on boot

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 712206

People

(Reporter: glandium, Unassigned)

References

Details

There are times of the day where we have a lot of slaves idle. Those slaves could run the clobberer script to trigger clobbers (forced or periodic). This would make those slaves *not* have to clobber when they start being used after having been idle.

Obviously, we can't make all idle slaves do that at the same time, so it would have to be weighted somehow.
Idle slaves get rebooted periodically.

I think slaves should run clobberer on boot, so that builds generally don't have to pay the cost of cleaning up directories.
Blocks: 712206
Summary: Trigger clobbers (if necessary) on idle slaves → Run clobberer on boot
QA Contact: john+bugzilla
No longer blocks: 712206
Depends on: 712206
Slave pre flight tasks are going to handle this.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712206
You need to log in before you can comment on or make changes to this bug.