background bugmail generation throws a "Can't store CODE items" error on dep_only changes

RESOLVED FIXED in Bugzilla 5.0

Status

()

Bugzilla
Email Notifications
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: glob, Assigned: glob)

Tracking

unspecified
Bugzilla 5.0
Bug Flags:
approval +

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
when generated dep_only bugmail while using the jobqueue:

[error] Inserting a <code>bug_mail</code> job into the Job Queue failed with the following error: Can't store CODE items at ../../lib/Storable.pm (autosplit into ../../lib/auto/Storable/_freeze.al) line 339, at /usr/local/share/perl5/TheSchwartz/Job.pm line 26 [#bd9723ff218a4990bd31f774739b7a81]
(Assignee)

Comment 1

4 years ago
Created attachment 822164 [details] [diff] [review]
930867_1.patch
Attachment #822164 - Flags: review?(simon)

Comment 2

4 years ago
Comment on attachment 822164 [details] [diff] [review]
930867_1.patch

I still can't reproduce the issue without the patch applied, but the patch looks okay and it doesn't break things, so it gets an r+ from me.
Attachment #822164 - Flags: review?(simon) → review+

Updated

4 years ago
Flags: approval?
Target Milestone: --- → Bugzilla 5.0

Updated

4 years ago
Flags: approval? → approval+
been almost a week since this was approved.  commit?
Flags: needinfo?(glob)
(Assignee)

Comment 4

4 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/BugMail.pm
Committed revision 8826.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(glob)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.