Army of Awesome is chock full of spammers

NEW
Unassigned

Status

support.mozilla.org
Army of Awesome
P3
normal
4 years ago
2 years ago

People

(Reporter: alex_mayorga, Unassigned)

Tracking

unspecified
2015Q4

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributor c=AoA p= s=2013.backlog)

(Reporter)

Description

4 years ago
Due to random reasons I ended up trying to do an "Army of Awesome All-nighter" but ended up rather frustrated at the sheer amount of spam that is there to be found at https://support.mozilla.org/en-US/army-of-awesome

I worked my way through the queue for a couple hours reporting the abusive accounts to twitter itself but the junk kept coming.

Basically anyone with 12+ character user name that has a capital letter or a digit in it is a spammer trying to get some replies.

Here are some of the suspicious tweets for reference:
https://twitter.com/massiernhjzSwan/status/393621412268625920
https://twitter.com/Shamee6agoBeeck/status/393613299100573697
https://twitter.com/sublidr3azHeune/status/393612982556454912
https://twitter.com/HopewellwrTschr/status/393610502162485248
https://twitter.com/pipless0zAuler0/status/393609066368339970
https://twitter.com/Anuratha2acAfen/status/393608979311378432
https://twitter.com/reinject6u0Agus/status/393608437768007680
https://twitter.com/foeishgk9bBjeli/status/393607358900760576
https://twitter.com/Apparao2kMaesa2/status/393606168993476608
https://twitter.com/deboiteuzSovelu/status/393605602561118208
https://twitter.com/nuttingglwBalth/status/393605101597638656
...

Hope you get the point...

If the back-end could automatically nuke any accounts that tweet the exact same message within a couple hours difference maybe this could be alleviated.

Thanks and keep the awesomeness up =)
(Reporter)

Comment 1

4 years ago
This is the spammy YouTube video most of the accounts link to http://www.youtube.com/watch?v=T205F1FON-8
(Reporter)

Comment 2

4 years ago
From IRC #SUMO :

4:27 AM <@Noah> from https://twitter.com/HopewellwrTschr/status/393610502162485248
4:27 AM <@Noah> actually looking at her profile, that's not spam
4:27 AM <@Noah> she seems real
4:28 AM <@Noah> but she has 0 followers which is weird as hell :S
4:28 AM <@Noah> maybe she has no friends :P
4:28 AM <alex_mayorga> Noah: Check her profile https://twitter.com/HopewellwrTschr
4:29 AM <alex_mayorga> See the "Photos and videos" section?
4:29 AM <alex_mayorga> See how all those are the very same thing?
4:30 AM <alex_mayorga> All are http://www.youtube.com/watch?v=T205F1FON-8 that is a "Get 5000 Twitter Follower http://bit.do/Followers " scam
4:32 AM <alex_mayorga> Noah: If I follow the rabbit hole, I get to http://bit.do/contact.php that is clearly an e-mail harvesting form...
There is no need to delete tweets. I simply ignore those that don't require a response. We pull tweets with the word Firefox in it and so it's basically better to ignore than take time to report each and every one because Twitter will get to it eventually and many of the accounts from the link provided in comment 0 are gone already and some still exist. 

There have been times where duplicate tweets are made and that is annoying but the best thing to do is just scroll past them.
OS: Windows 7 → All
Hardware: x86_64 → All
(Reporter)

Comment 4

4 years ago
The accounts that are gone are so because I go through the extra hassle of <Ctrl>+click every account I reply to and report anything that doesn't look legit.

I think spammers have figured out that "Army of Awesome" might yields them a reply by just dropping "Firefox" into their random gibberish.

Maybe just remove any tweets that are duplicates from the queue.

For example, right now these messages are clearly from spammers as they appear twice or more times in the queue:

"i officially hate my computer, mozilla firefox, and internet explorer. this computer sucks. mozilla firefox sucks. internet explorer sucks!"

"Dudeeee, wtefff. I try to upgrade firefox but when it's done, it "cant" connect to the internet or something. Wtheckkkk. Im mad."
OS: All → Windows 7
Hardware: All → x86_64
Maybe this bug can be a bug to remove duplicate tweets. If you didn't expect to see spam, that's not normal. Also what is wrong with sending a reply to a spammer having an issue? As said, its okay to ignore them. What issue did you want resolved with this bug? Also, why is hardware and os changed back? It makes no difference.

Comment 6

4 years ago
Maybe Topal has some info on this?
Flags: needinfo?(a.topal)
I did a report on the spam issue earlier this year: https://docs.google.com/a/mozilla.com/document/d/1UaceaoFslXWNBuEfrD7VVMt4Rjp7hV4nD1gUQOfVuw4/edit#

I read 500 tweets from our database and categorized them by spam, non-spam, and actionable. Only 7% of all tweets were spam tweets, but a huge number of tweets were just not actionable. We should probably run that again to see what we are dealing with. Killing spam could be relatively simple, while killing the non-actionable tweets is extremely difficult.

Unfortunately I won't have the time to run this test within this year. If anyone else is up for it, let me know and I can give you a list of tweets to go through.

Also, Twitter seems to be taking spam problems more seriously. They are looking for an anti-spam product manager: http://www.linkedin.com/jobs2/view/9656062?trk=jobs_search_public_seo_page
Flags: needinfo?(a.topal)

Updated

4 years ago
Priority: -- → P3
Whiteboard: u=contributor c=AoA p= s=2013.backlog
Target Milestone: --- → 2014Q1

Comment 8

4 years ago
The above all are fack account and almost all of the above account are  Account suspended ....
Duplicate of this bug: 964227
Any change for this to be worked on this quarter?
OS: Windows 7 → All
Hardware: x86_64 → All
Duplicate of this bug: 973148

Comment 12

4 years ago
I see that bug 973148 is a RESOLVED DUPLICATE of this bug, however this bug is marked as new. Any update?
The bug is not resolved actually. I can still see a lot of spam tweets which are not filtered out.  Please refer to the AoA page for more details.(In reply to Moses Bermea from comment #12)
> I see that bug 973148 is a RESOLVED DUPLICATE of this bug, however this bug
> is marked as new. Any update?
This is planned to be worked on this quarter.  We need to await for Madalina/Kadir/Ricky for more info atm.
(In reply to rajrohit from comment #13)
> The bug is not resolved actually. I can still see a lot of spam tweets which
> are not filtered out.  Please refer to the AoA page for more details.(In
> reply to Moses Bermea from comment #12)
> > I see that bug 973148 is a RESOLVED DUPLICATE of this bug, however this bug
> > is marked as new. Any update?

"RESOLVED DUPLICATED" means that the bug has a resolution: it is a duplicate of another bug. It doesn't mean the problem was fixed (that would be RESOLVED FIXED). In this case bug 973148 was marked as a duplicate of this bug (bug 930914), which means they are covering the same topic, and we only need one. Because this bug is still status NEW, that means we haven't worked on this bug yet.
Q1 is over. Bring it on, Q2!
Target Milestone: 2014Q1 → 2014Q2
(Reporter)

Comment 17

2 years ago
2014 is over, Bring it on, 2015! =)
Target Milestone: 2014Q2 → 2015Q4
I think per comment 7, we still need to look into this. I at this moment do not have time to go through a list of tweets to sort. However, I can do this over the span of a few months which may not a be a viable solution..
You need to log in before you can comment on or make changes to this bug.