css namespace didnt apply by dynamic load content

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
5 years ago
2 years ago

People

(Reporter: Andrey, Unassigned)

Tracking

24 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.76 KB, application/x-zip-compressed
Details
(Reporter)

Description

5 years ago
Created attachment 822224 [details]
bug.zip - include all example files

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

Steps to reproduce:

I have two xhtml files:
first (include.xhtml): 
----------------------------

<html 
xmlns="http://www.w3.org/1999/xhtml" 
xmlns:myspace="http://www.mynamespace.com/"
>
<head>
<style type="text/css">
	@namespace myspace "http://www.mynamespace.com/";
	body {
		background-color: cyan;
	}
	*[myspace|indf='someelement'] {
		background-color: red;
	}
</style>
</head>
<body>
	Lorem ipsum dolor sit amet, <span myspace:indf="someelement">consectetur adipisicing elit</span>, sed do eiusmod tempor incididunt ut labore
</body>
</html>

----------------
second (index_dom.xhtml):
----------------

<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<script  type="text/javascript">
	function load(){
		var xhr = new XMLHttpRequest();
		xhr.open('GET', "./include.xhtml", true);
		xhr.onload = function(e) {
			myFrame.document.write(this.response);
	 		myFrame.document.close();
		};
		xhr.send();
	}
</script>
</head>
<body onload="load()">
	<iframe id="myFrame"/>
</body>

</html>

----------------------
I open index_dom.xhtml



Actual results:

css style *[myspace|indf='someelement']  does not apply for <span> element after include.xhtml has been loaded to iframe. But another styles were applied.


Expected results:

css style *[myspace|indf='someelement']   must be applied for element inside iframe.

if I use iframe.src = "./include.xhtml" instead dynamic content load all styles works fine.
Hi,

Could you please provide a simplified testcase where this issue is reproducible? Here is a page that might help you to provide one (https://jsfiddle.net/). 

Also please try to reproduce this on the latest Firefox release(43.0.4) and latest Nightly (https://nightly.mozilla.org) and provide the results? When doing this, please try to reproduce with a new clean Firefox profile, maybe even in safe mode, as some of this issues may be caused by third party installed add-ons or custom settings(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thanks,
Cipri
Flags: needinfo?(utes)
Since the reporter didn't provide the requested information, I will mark this issue as RESOLVED INCOMPLETE. If you still encounter this problem, please feel free to reopen this bug, or file a new one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(utes)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.