Hovering on links causes display problems (:hover only doing first line)

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
17 years ago
4 years ago

People

(Reporter: Chi-Thanh Christopher Nguyen, Assigned: Chris Waterson)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P2], URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.2+) Gecko/20010729
BuildID:    2001072910

http://www.powervr.com/Downloads.asp and other pages on that site are not
displayed correctly when hovering the mouse pointer over some links.
(Using Win98 and Solaris Builds 20010729)


Reproducible: Always
Steps to Reproduce:
1. Go to http://www.powervr.com/Downloads.asp
2. Move the mouse pointer onto the links


Actual Results:  Hovering on the 'Drivers' or 'Benchmarks' links will add/remove
a blank line; pointing at 'Benchmarks' then 'Drivers' (don't click) and then one
of the images or links below causes rendering errors.
Afterwards, the 'White Papers' links on the bottom will disappear.

When pointing/clicking at the 'What the Press say' links, some of them will not
be highlighted entirely.
Afterwards, the 'White Papers' links on the bottom will disappear.


Expected Results:  Text elements should not move around or disappear, links
should be highlighted correctly.

This also occurs, in a somewhat less serious form, on the 0.9.2 release.
It could be related to bug 91062 although the text size is not being changed here.

Comment 1

17 years ago
Confirmed with build 2001080508 win32

I'm not sure but this may be related to bug 82946

Reporter, would you mind creating a more simplified testcase so that the cause
of the problem is narrowed down? Thanks!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
WFM, build 2001-08-08-04 on Windows 98 SE.
Assignee: pierre → karnaze
Component: Style System → Layout
QA Contact: ian → petersen
(Reporter)

Comment 3

17 years ago
Indeed, the disappearing text and insertion of blank lines issues seem to be
resolved with bug 91062. But the 'What the Press say' links are still not being
highlighted as they should. I will try to provide a testcase for this.
(Reporter)

Comment 4

17 years ago
It looks like the cause for all this is a faulty stylesheet. Why was the
component changed to layout?
(Reporter)

Comment 5

17 years ago
Created attachment 45435 [details]
faulty stylesheet causing problems
(Reporter)

Comment 6

17 years ago
Created attachment 45437 [details]
testcase

Comment 7

17 years ago
sending back to style system for evaluation

confirming what is seen in the testcase, maybe a compositor bug?
Assignee: karnaze → pierre
Component: Layout → Style System
QA Contact: petersen → ian

Comment 8

17 years ago
I was just about to post a new bug, but thankfully found this one was already
started.  My report/comments are quite similar, but expand a few of the
details/problems.

I have included a testcase that includes a few more small quirks that aren't
listed here.  I am using Windows ME, and Build: 20010818.

I fail to have the same problems with **cough** Internet Explorer version 5.5
**cough cough**   <-- a nasty cough   ;)

Listed below are the notes I have included within my testcase, but they are
provided here for your benefit.  Please refer to the actual testcase when
following these steps, or referring to my notes.

-------
The only style defined on this page (in the header):

a:hover {font-weight: bold}


Steps to reproduce the many problems:

   1. Hover your mouse over the link - only the FIRST line is rendered bold
   2. Click, but do NOT release on the link - the first line PLUS THE NEXT TWO
lines are rendered bold
   3. Release the button, and watch the three lines render bold PLUS THE NEXT ONE
   4. After clicking the link, notice those four lines are still rendered bold
   5. Now, Move your mouse pointer off of the link (un-hover), and notice that
the FIRST line returns to normal font-weight, but all the rest of the lines that
were bold now remain rendered as bold.
   6. With your mouse pointer in an empty (white space) area, click the mouse
once. The SECOND line should "un-bold" itself, but res of the lines that were
bold now remain rendered bold
   7. Repeat the process from step one, until the entire link remains bold (or
until you get the idea)
   8. Only a Reload of the page will return links back to an "un-bold" state


Notes:

    * This "problem" happens with other attributes besides "bold". You can also
get the same effect if making a link "italic" or "oblique" (etc.) This appears
to be a problem with the "link" formatting, and not a problem with the
"font-weight" or "font-style" (my guess)
    * The link used above points to a 'top' target on the page. I did that so
you could see the link after you click on it. However, this problem exists for
an internal/external link as well.
    * The current page uses no tables, divs or any positioning information-- so
we can have a "pure" testcase. In the "real world", a web developer might want
to include a link inside a "table" or "div" (etc.) with a small width. In this
case, there is a great possibility that links will wrap on their page.

Comment 9

17 years ago
Created attachment 46403 [details]
Testcase for Ryan Pertusio - a few more details and new quirks

Comment 10

17 years ago
Sorry for spam... Adding to CC

Updated

17 years ago
Keywords: testcase

Comment 11

17 years ago
Also to note (and correction)   [getting tired of my posts yet? sorry!]

 I have listed that I used a build from the 18th, but rather I meant the 17th. 
I indeed downloaded on the 18th, but for some reason, the latest build has been
from the 17th (someone know why?)
 My platforms I have noticed the problem include Windows Millennium, and
Windows2000.

 Yet another thing to notice with this bug: On pages with many links (about 10
or more) that receive a 'bold' attribute (and probably any other attribute like
'oblique' or 'italic'), Mozilla seems to choke up.  What I mean is it really
slows down when you hover over a link.  It seems to take a fraction of a second
longer to render the link.  When moving from link to link (hovering, that is),
there may be as much as a one second delay while the previously hovered link
'un-bolds' itself, and 'bolds' the one you are currently hovering.
  Using win2000, the processor usage pops up to 100% while moving across those
links.  If needed, I will add a testcase for this problem too.  OR, maybe I
should start that specific problem as a perf bug.
(questions/comments?)
Chi-Thanh Christopher Nguyen: The "layout" component is related to what a style
sheet makes the page *look* like, the "style system" component is related to how
we actually read the stylesheet itself. In this case, it is a layout problem.

Ryan Pertusio: Nice test case! Thanks!

Chris Waterson: This looks like a line or continuation bug you might know about.
Assignee: pierre → waterson
Component: Style System → Layout
Whiteboard: [Hixie-P2] [Hixie-1.0]
Summary: Hovering on links causes display problems → Hovering on links causes display problems (:hover only doing first line)

Comment 13

17 years ago
At least part of this bug is a duplicate of bug 98783.  Is all of it?  If the
only remaining issues are duplicate of bug 98783, this bug should be marked a
duplicate of bug 98783 since bug 98783 is clearer.  If not, the other issues
should be split off into separate bugs and this one should be marked a duplicate
of one of the bugs, since this bug is confusing (it describes multiple issues)
and should be closed.
(Reporter)

Comment 14

17 years ago
The remaining issues are due to the :hover not being applied as it should. See
attachment  46403 [details]. (as you will notice, :hover can "permanently" do other lines
than the first by clicking the link)
The other issues have already been dealt with in bug 91062.

(Assignee)

Updated

17 years ago
Target Milestone: --- → Future
Whiteboard: [Hixie-P2] [Hixie-1.0] → [Hixie-P2]
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
I don't know if this is the same bug, but in the website
http://www.aranhamagazine.com.br the links of the right side of the site has the
background hover image blinking when you mouse over them, my cache options are:
no memory cache,no disk cache and compare page never.

I'm using the build(2002021303).
Sorry for the comment above, it may be for the bug 111338 :(

Comment 17

17 years ago
Not seeing this bug on Win98, 2002022203 (all test cases examined). Please
reopen if it's platform/os specific.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 18

17 years ago
I think this was a dup of bug 98783
You need to log in before you can comment on or make changes to this bug.