Closed Bug 931043 Opened 6 years ago Closed 6 years ago

don't use AC_TRY_RUN to check for how to copy va_args

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla28

People

(Reporter: froydnj, Unassigned)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

It doesn't work in cross configurations, and we just get lucky with our current crosses.

I appreciate the zealousness of making sure things run, but a simple compile check should be enough to see whether we have the right bits.
We shouldn't need to run these programs; compiling them should be enough.

While we're at it, we can remove support for __va_copy, which, AFAICS, is an
old GNU extension and has been superseded by va_copy by anyplace that cares.
Attachment #822375 - Flags: review?(mh+mozilla)
Attachment #822375 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/7a079294517b
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Duplicate of this bug: 934981
Whiteboard: [qa-]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.