Closed Bug 931052 Opened 6 years ago Closed 6 years ago

crash in js::GlobalObject::getDebuggers()

Categories

(Core :: JavaScript Engine, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 930427

People

(Reporter: standard8, Unassigned)

Details

(Keywords: crash)

Crash Data

Sometimes when I close the debugger I'm seeing this crash. STR today where:

1) Open the debugger
2) Wait about 10 mins
3) Close the debugger

This is only occasional, for me happening on Mac OS X.

Typical stacks:

bp-226f431d-4111-48f7-a4ce-26d802131021
bp-250b4605-b569-411c-8592-6be9c2131018
bp-e87f4723-eca7-43ec-8993-1d2182131015
bp-913e63d2-d2ab-4afc-aec8-a8fd32131025

0 	XUL 	js::GlobalObject::getDebuggers() 	js/src/jsfriendapi.h
1 	XUL 	js::Debugger::removeDebuggeeGlobal(js::FreeOp*, js::GlobalObject*, js::AutoDebugModeGC&, js::detail::HashTable<js::GlobalObject* const, js::HashSet<js::GlobalObject*, js::DefaultHasher<js::GlobalObject*>, js::SystemAllocPolicy>::SetOps, js::SystemAllocPolicy>::Enum*, js::detail::HashTable<js::GlobalObject* const, js::HashSet<js::GlobalObject*, js::DefaultHasher<js::GlobalObject*>, js::SystemAllocPolicy>::SetOps, js::SystemAllocPolicy>::Enum*) 	js/src/vm/Debugger.cpp
2 	XUL 	js::Debugger::removeAllDebuggees(JSContext*, unsigned int, JS::Value*) 	js/src/vm/Debugger.cpp
3 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/jscntxtinlines.h
4 	XUL 	Interpret 	js/src/vm/Interpreter.cpp
5 	XUL 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
6 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
7 	XUL 	js::CallOrConstructBoundFunction(JSContext*, unsigned int, JS::Value*) 	js/src/jsfun.cpp
8 	XUL 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct)
Crash stacks show this happening on all platforms.

To clarify the steps to repeat, I was using the Remote/Browser Debugger, and closing it crashed the main Firefox process that it was debugging.
OS: Mac OS X → All
(In reply to Mark Banner (:standard8) from comment #1)
> Crash stacks show this happening on all platforms.
> 
> To clarify the steps to repeat, I was using the Remote/Browser Debugger, and
> closing it crashed the main Firefox process that it was debugging.

Same STR for me too.
I got a crash. These steps worked:

1.  about:config, set devtools.debugger.remote-enabled to true
2.  Tools -> Web Developer -> Browser Debugger
3.  click around randomly in confusion, pausing and restarting JS several times
4.  surf the web for a few minutes
5.  close the browser debugger

At that point the debuggee crashes. I got a slightly different stack:

https://crash-stats.mozilla.com/report/index/a556498a-ff2c-48ec-b7fc-91e662131121
Crash Signature: [@ js::GlobalObject::getDebuggers()] → [@ js::GlobalObject::getDebuggers()] [@ js::WeakMap<js::EncapsulatedPtr<JSScript, unsigned long>, js::RelocatablePtr<JSObject>, js::DefaultHasher<js::EncapsulatedPtr<JSScript, unsigned long> > >::nonMarkingTraceKeys(JSTracer*)]
This looks like a duplicate of the bug that ended up adding invisible compartments as debuggees. Feel free to re-open if this persists.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 930427
You need to log in before you can comment on or make changes to this bug.